summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/packagegroups/packagegroup-basic.bb')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-basic.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb
new file mode 100644
index 000000000..20b16527e
--- /dev/null
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb
@@ -0,0 +1,55 @@
1# This recipe is intended as a 'simpler' replacement for packagegroup-base.
2# Please communicate your use cases and suggestions to the mailinglist(s)
3
4SUMMARY = "Basic task to get a device online"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
7
8PR = "r13"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11inherit packagegroup
12
13# Poke extra recomendations into the list using your machine.conf
14#
15MACHINE_EXTRA_RRECOMMENDS ?= ""
16
17#
18# Select between dropbear and openssh
19# Set TASK_BASIC_SSHDAEMON = "openssh-sshd openssh-sftp openssh-sftp-server" in your DISTRO config to get openssh(d)
20#
21TASK_BASIC_SSHDAEMON ?= "dropbear openssh-sftp openssh-sftp-server"
22
23#
24# The section below is designed to match with packagegroup-boot, but doesn't depend on it to allow for more freedom
25# when writing image recipes.
26# It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a
27# distro feature.
28#
29# Util-linux (u)mount is included because the busybox one can't handle /etc/mtab being symlinked to /proc/mounts
30#
31RDEPENDS_${PN} = "\
32 ${TASK_BASIC_SSHDAEMON} \
33 avahi-daemon avahi-utils \
34"
35
36#
37# The following section is split in 3:
38# 1) Machine features: kernel modules and userspace helpers for those
39# 2) Distro features: packages associated with those
40# 3) Nice to have: packages that are nice to have, but aren't strictly needed
41#
42RRECOMMENDS_${PN} = "\
43 ${MACHINE_EXTRA_RRECOMMENDS} \
44 ${@base_contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \
45 ${@base_contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \
46 ${@base_contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \
47 \
48 ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4", "", d)} \
49 ${@base_contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \
50 \
51 tzdata \
52 \
53 cpufrequtils \
54 htop \
55"