summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/ndctl/ndctl_v63.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/ndctl/ndctl_v63.bb')
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl_v63.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/ndctl/ndctl_v63.bb b/meta-oe/recipes-core/ndctl/ndctl_v63.bb
new file mode 100644
index 000000000..17f340592
--- /dev/null
+++ b/meta-oe/recipes-core/ndctl/ndctl_v63.bb
@@ -0,0 +1,29 @@
1SUMMARY = "libnvdimm utility library"
2DESCRIPTION = "Utility library for managing the libnvdimm \
3(non-volatile memory device) sub-system in the Linux kernel. \
4The LIBNVDIMM subsystem provides support for three types of \
5NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \
6simultaneously support both PMEM and BLK mode access."
7HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=e66651809cac5da60c8b80e9e4e79e08"
10
11inherit autotools-brokensep pkgconfig module-base bash-completion systemd
12
13SRCREV = "cb2d678dd6d286dd96d31548c32449a8b883ae32"
14SRC_URI = "git://github.com/pmem/ndctl.git"
15
16DEPENDS = "virtual/kernel kmod udev json-c"
17
18S = "${WORKDIR}/git"
19
20EXTRA_OECONF += "--enable-test --enable-destructive --disable-docs"
21
22PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
23PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd, systemd"
24
25do_configure_prepend() {
26 ${S}/autogen.sh
27}
28
29SYSTEMD_SERVICE_${PN} = "ndctl-monitor.service"