summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/samba/samba_3.6.24.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/samba/samba_3.6.24.bb')
-rw-r--r--meta-oe/recipes-connectivity/samba/samba_3.6.24.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/samba/samba_3.6.24.bb b/meta-oe/recipes-connectivity/samba/samba_3.6.24.bb
new file mode 100644
index 000000000..8860da088
--- /dev/null
+++ b/meta-oe/recipes-connectivity/samba/samba_3.6.24.bb
@@ -0,0 +1,67 @@
1require samba.inc
2require samba-basic.inc
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://../COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
6SRC_URI += "\
7 file://config-h.patch \
8 file://documentation.patch;patchdir=.. \
9 file://documentation2.patch;patchdir=.. \
10 file://fhs-filespaths.patch;patchdir=.. \
11 file://installswat.sh.patch;patchdir=.. \
12 file://pam-examples.patch;patchdir=.. \
13 file://smbclient-pager.patch;patchdir=.. \
14 file://undefined-symbols.patch;patchdir=.. \
15 file://usershare.patch;patchdir=.. \
16 file://smbtar-bashism.patch;patchdir=.. \
17 file://dont-build-VFS-examples.patch;patchdir=.. \
18 file://bug_221618_precise-64bit-prototype.patch;patchdir=.. \
19 file://bug_598313_upstream_7499-nss_wins-dont-clobber-daemons-logs.patch;patchdir=.. \
20 file://bug_387266_upstream_4104_mention-kerberos-in-smbspool-manpage.patch;patchdir=.. \
21 file://bug_604768_upstream_7826_drop-using-samba-link.patch;patchdir=.. \
22 file://bug_604768_upstream_7826_fix-WHATSNEW-link.patch;patchdir=.. \
23 file://waf-as-source.patch;patchdir=.. \
24 file://smbtorture-manpage.patch;patchdir=.. \
25 file://libutil_drop_AI_ADDRCONFIG.patch;patchdir=.. \
26 file://shadow_copy2_backport.patch;patchdir=.. \
27 file://only_export_public_symbols.patch;patchdir=.. \
28 file://configure-disable-getaddrinfo-cross.patch;patchdir=.. \
29 file://configure-disable-core_pattern-cross-check.patch;patchdir=.. \
30 file://configure-libunwind.patch;patchdir=.. \
31"
32SRC_URI[md5sum] = "d98425c0c2b73e08f048d31ffc727fb0"
33SRC_URI[sha256sum] = "11d0bd04b734731970259efc6692b8e749ff671a9b56d8cc5fa98c192ab234a7"
34
35S = "${WORKDIR}/samba-${PV}/source3"
36
37PACKAGECONFIG ??= ""
38PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
39
40EXTRA_OECONF += "\
41 ac_cv_path_PYTHON=/not/exist \
42 ac_cv_path_PYTHON_CONFIG=/not/exist \
43 SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
44 samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
45 linux_getgrouplist_ok=no \
46 samba_cv_HAVE_BROKEN_GETGROUPS=no \
47 samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
48 samba_cv_have_setresuid=yes \
49 samba_cv_have_setresgid=yes \
50 samba_cv_HAVE_WRFILE_KEYTAB=yes \
51 samba_cv_linux_getgrouplist_ok=yes \
52"
53
54do_configure() {
55 gnu-configize --force
56 oe_runconf
57}
58
59do_compile () {
60 base_do_compile
61}
62
63do_install_append() {
64 rmdir "${D}${localstatedir}/lock"
65 rmdir "${D}${localstatedir}/run"
66 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
67}