summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/samba/samba/configure-3.3.0.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/samba/samba/configure-3.3.0.patch')
-rw-r--r--meta-oe/recipes-connectivity/samba/samba/configure-3.3.0.patch85
1 files changed, 85 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/samba/samba/configure-3.3.0.patch b/meta-oe/recipes-connectivity/samba/samba/configure-3.3.0.patch
new file mode 100644
index 000000000..19fb9864d
--- /dev/null
+++ b/meta-oe/recipes-connectivity/samba/samba/configure-3.3.0.patch
@@ -0,0 +1,85 @@
1diff -urN source.old//configure source//configure
2--- source.old//configure 2009-01-27 07:53:11.000000000 +0000
3+++ source//configure 2009-01-31 21:07:25.811887936 +0000
4@@ -43860,13 +43860,7 @@
5 *linux*)
6 # glibc <= 2.3.2 has a broken getgrouplist
7 if test "$cross_compiling" = yes; then
8- { { $as_echo "$as_me:$LINENO: error: in \`$ac_pwd':" >&5
9-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
10-{ { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling
11-See \`config.log' for more details." >&5
12-$as_echo "$as_me: error: cannot run test program while cross compiling
13-See \`config.log' for more details." >&2;}
14- { (exit 1); exit 1; }; }; }
15+linux_getgrouplist_ok=no
16 else
17 cat >conftest.$ac_ext <<_ACEOF
18 /* confdefs.h. */
19diff -urN source.old//configure.in source//configure.in
20--- source.old//configure.in 2009-01-26 13:56:34.000000000 +0000
21+++ source//configure.in 2009-01-31 21:04:39.051889949 +0000
22@@ -280,6 +280,8 @@
23 fi
24 AC_SUBST(BROKEN_CC)
25
26+AC_TRY_COMPILE([],[(void)sizeof(char[-1])],AC_MSG_ERROR([configure's compilation assert doesn't work with $CC]))
27+
28 dnl Check if the C compiler understands -Werror
29 AC_CACHE_CHECK([that the C compiler understands -Werror],samba_cv_HAVE_Werror, [
30 AC_TRY_RUN_STRICT([
31@@ -330,25 +332,11 @@
32 # a runtime test is needed here
33 AC_SUBST(PIDL_ARGS)
34 AC_CACHE_CHECK([that the C compiler understands negative enum values],samba_cv_CC_NEGATIVE_ENUM_VALUES, [
35- AC_TRY_RUN(
36+ AC_TRY_COMPILE([],
37 [
38- #include <stdio.h>
39 enum negative_values { NEGATIVE_VALUE = 0xFFFFFFFF };
40- int main(void) {
41- enum negative_values v1 = NEGATIVE_VALUE;
42- unsigned v2 = NEGATIVE_VALUE;
43-
44- if (v1 != 0xFFFFFFFF) {
45- printf("%u != 0xFFFFFFFF\n", v1);
46- return 1;
47- }
48- if (v2 != 0xFFFFFFFF) {
49- printf("%u != 0xFFFFFFFF\n", v2);
50- return 1;
51- }
52-
53- return 0;
54- }
55+ (void)sizeof(char[1-2*( (unsigned)NEGATIVE_VALUE != 0xFFFFFFFF)]);
56+ (void)sizeof(char[1-2*((enum negative_values)NEGATIVE_VALUE != 0xFFFFFFFF)]);
57 ],
58 samba_cv_CC_NEGATIVE_ENUM_VALUES=yes,samba_cv__CC_NEGATIVE_ENUM_VALUES=no)])
59 if test x"$samba_cv_CC_NEGATIVE_ENUM_VALUES" != x"yes"; then
60@@ -1224,22 +1212,12 @@
61 case "$host_os" in
62 *linux*)
63 # glibc <= 2.3.2 has a broken getgrouplist
64- AC_TRY_RUN([
65-#include <unistd.h>
66+ AC_TRY_COMPILE([
67 #include <sys/utsname.h>
68-main() {
69- /* glibc up to 2.3 has a broken getgrouplist */
70+],[
71 #if defined(__GLIBC__) && defined(__GLIBC_MINOR__)
72- int libc_major = __GLIBC__;
73- int libc_minor = __GLIBC_MINOR__;
74-
75- if (libc_major < 2)
76- exit(1);
77- if ((libc_major == 2) && (libc_minor <= 3))
78- exit(1);
79+ (void)sizeof(char[1-2*(__GLIBC__ < 2 || __GLIBC__ == 2 && __GLIBC_MINOR__ <= 3)]);
80 #endif
81- exit(0);
82-}
83 ], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no])
84 if test x"$linux_getgrouplist_ok" = x"yes"; then
85 AC_DEFINE(HAVE_GETGROUPLIST, 1, [Have good getgrouplist])