summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/samba/samba-3.6.24/undefined-symbols.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/samba/samba-3.6.24/undefined-symbols.patch')
-rw-r--r--meta-oe/recipes-connectivity/samba/samba-3.6.24/undefined-symbols.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/samba/samba-3.6.24/undefined-symbols.patch b/meta-oe/recipes-connectivity/samba/samba-3.6.24/undefined-symbols.patch
new file mode 100644
index 000000000..5babc1e38
--- /dev/null
+++ b/meta-oe/recipes-connectivity/samba/samba-3.6.24/undefined-symbols.patch
@@ -0,0 +1,24 @@
1Description: Fix missing symbols
2 Fix missing symbols in libsmbclient (and libnss_wins), and add
3 -Wl,-z,defs to the libsmbclient link options to prevent future
4 instances of undefined symbols.
5 .
6 This should be forwarded upstream once there's a configure test
7 for it.
8Author: Steve Langasek <vorlon@debian.org>
9Bug-Debian: http://bugs.debian.org/281181
10Forwarded: no
11
12Index: experimental/source3/Makefile.in
13===================================================================
14--- experimental.orig/source3/Makefile.in
15+++ experimental/source3/Makefile.in
16@@ -2594,7 +2594,7 @@
17
18 $(LIBSMBCLIENT_SHARED_TARGET_SONAME): $(BINARY_PREREQS) $(LIBSMBCLIENT_OBJ) $(LIBSMBCLIENT_THREAD_OBJ) $(LIBSMBCLIENT_SYMS) $(LIBTALLOC) $(LIBTEVENT) $(LIBTDB) $(LIBWBCLIENT)
19 @echo Linking shared library $@
20- @$(SHLD_DSO) $(LIBSMBCLIENT_OBJ) $(LIBSMBCLIENT_THREAD_OBJ) \
21+ @$(SHLD_DSO) -Wl,-z,defs $(LIBSMBCLIENT_OBJ) $(LIBSMBCLIENT_THREAD_OBJ) \
22 $(LIBTALLOC_LIBS) $(LIBTEVENT_LIBS) $(LIBTDB_LIBS) $(LIBWBCLIENT_LIBS) $(LIBS) \
23 $(KRB5LIBS) $(LDAP_LIBS) $(NSCD_LIBS) $(ZLIB_LIBS) $(PTHREAD_LDFLAGS) \
24 @SONAMEFLAG@`basename $@`