summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/obex/openobex_1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/obex/openobex_1.5.bb')
-rw-r--r--meta-oe/recipes-connectivity/obex/openobex_1.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/obex/openobex_1.5.bb b/meta-oe/recipes-connectivity/obex/openobex_1.5.bb
new file mode 100644
index 000000000..b07779dd5
--- /dev/null
+++ b/meta-oe/recipes-connectivity/obex/openobex_1.5.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "The Openobex project is an open source implementation of the \
2Object Exchange (OBEX) protocol."
3HOMEPAGE = "http://openobex.triq.net"
4SECTION = "libs"
5DEPENDS = "virtual/libusb0 bluez4"
6LICENSE = "GPLv2 & LGPLv2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
8 file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
9"
10
11SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/openobex-${PV}.tar.gz \
12 file://disable-cable-test.patch \
13 file://libusb_crosscompile_check.patch \
14 file://separate_builddir.patch"
15
16SRC_URI[md5sum] = "0d83dc86445a46a1b9750107ba7ab65c"
17SRC_URI[sha256sum] = "e602047570799a47ecb028420bda8f2cef41310e5a99d084de10aa9422935e65"
18
19inherit autotools binconfig pkgconfig
20
21EXTRA_OECONF = "--enable-apps --enable-syslog"
22
23do_install_append() {
24 install -d ${D}${datadir}/aclocal
25 install -m 0644 ${S}/openobex.m4 ${D}${datadir}/aclocal
26}
27
28PACKAGES += "openobex-apps"
29FILES_${PN} = "${libdir}/lib*.so.*"
30FILES_${PN}-dev += "${bindir}/openobex-config"
31FILES_${PN}-apps = "${bindir}/*"
32DEBIAN_NOAUTONAME_${PN}-apps = "1"
33