summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb')
-rw-r--r--meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb b/meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb
new file mode 100644
index 000000000..5a8e336b9
--- /dev/null
+++ b/meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb
@@ -0,0 +1,38 @@
1# NOTE: mosh-server requires a UTF-8 locale, but there's no way to add
2# an explicit dependency for this so you need to ensure this is in your
3# image yourself when you install mosh-server.
4
5SUMMARY = "Remote shell supporting roaming and high-latency connections"
6DESCRIPTION = "Remote terminal application that allows roaming, supports \
7intermittent connectivity, and provides intelligent local echo and line \
8editing of user keystrokes. Mosh is a replacement for SSH. It's more \
9robust and responsive, especially over Wi-Fi, cellular, and \
10long-distance links."
11HOMEPAGE = "http://mosh.mit.edu"
12LICENSE = "GPLv3+"
13LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
14
15DEPENDS = "protobuf-native protobuf ncurses zlib libio-pty-perl openssl"
16
17SRC_URI = "http://mosh.mit.edu/mosh-${PV}.tar.gz"
18
19SRC_URI[md5sum] = "c2d918f4d91fdc32546e2e089f9281b2"
20SRC_URI[sha256sum] = "e74d0d323226046e402dd469a176075fc2013b69b0e67cea49762c957175df46"
21
22inherit autotools
23
24PACKAGE_BEFORE_PN += "${PN}-server"
25FILES_${PN}-server = "${bindir}/mosh-server"
26
27NEEDED_PERL_MODULES = "\
28 perl-module-socket \
29 perl-module-getopt-long \
30 perl-module-errno \
31 perl-module-io-socket-inet \
32 perl-module-posix \
33"
34
35# mosh uses SSH to authenticate and the client uses OpenSSH-specific features
36RDEPENDS_${PN} += "openssh-ssh ${NEEDED_PERL_MODULES}"
37# The server seemed not to work with dropbear either
38RDEPENDS_${PN}-server += "openssh-sshd ${NEEDED_PERL_MODULES}"