summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.7.991.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/modemmanager/modemmanager_1.7.991.bb')
-rw-r--r--meta-oe/recipes-connectivity/modemmanager/modemmanager_1.7.991.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.7.991.bb b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.7.991.bb
new file mode 100644
index 000000000..4f9400169
--- /dev/null
+++ b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.7.991.bb
@@ -0,0 +1,50 @@
1SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
2DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
4LICENSE = "GPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit gnomebase gettext systemd vala gobject-introspection bash-completion
11
12DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native"
13
14SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz"
15
16SRC_URI[md5sum] = "4efe6a240cef212bf8855c95424e7c7f"
17SRC_URI[sha256sum] = "4e366243bd4983f2e6efe35cb901cf5da51939307b5d6299fe622a9fcf411745"
18
19S = "${WORKDIR}/ModemManager-${PV}"
20
21PACKAGECONFIG ??= "mbim qmi polkit \
22 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
23"
24
25PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,"
26PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit"
27# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
28PACKAGECONFIG[mbim] = "--with-mbim,--enable-mbim=no,libmbim"
29# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
30PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi"
31
32FILES_${PN} += " \
33 ${datadir}/icons \
34 ${datadir}/polkit-1 \
35 ${datadir}/dbus-1 \
36 ${libdir}/ModemManager \
37 ${systemd_unitdir}/system \
38"
39
40FILES_${PN}-dev += " \
41 ${libdir}/ModemManager/*.la \
42"
43
44FILES_${PN}-staticdev += " \
45 ${libdir}/ModemManager/*.a \
46"
47
48FILES_${PN}-dbg += "${libdir}/ModemManager/.debug"
49
50SYSTEMD_SERVICE_${PN} = "ModemManager.service"