summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/libtorrent/libtorrent_0.14.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/libtorrent/libtorrent_0.14.0.bb')
-rw-r--r--meta-oe/recipes-connectivity/libtorrent/libtorrent_0.14.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/libtorrent/libtorrent_0.14.0.bb b/meta-oe/recipes-connectivity/libtorrent/libtorrent_0.14.0.bb
new file mode 100644
index 000000000..912b00261
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libtorrent/libtorrent_0.14.0.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "libTorrent is a BitTorrent library written in C++ for *nix, \
2with a focus on high performance and good code."
3HOMEPAGE = "http://libtorrent.rakshasa.no/"
4LICENSE = "GPL-2.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
6
7DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
8
9SRC_URI = "git://github.com/rakshasa/libtorrent;branch=master;protocol=https"
10SRCREV = "08fb6635ba249665cb08a4de1b955288d25c21e1"
11
12UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
13
14CVE_STATUS[CVE-2009-1760] = "backported-patch: patched in our product"
15
16S = "${WORKDIR}/git"
17
18CVE_PRODUCT = ""
19
20PACKAGECONFIG ??= "instrumentation aligned"
21
22PACKAGECONFIG:remove:mipsarch = "instrumentation"
23PACKAGECONFIG:remove:powerpc = "instrumentation"
24PACKAGECONFIG:remove:riscv32 = "instrumentation"
25
26PACKAGECONFIG[instrumentation] = "--enable-instrumentation,--disable-instrumentation,"
27PACKAGECONFIG[aligned] = "--enable-aligned,--disable-aligned,"
28
29inherit autotools pkgconfig
30
31EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"