summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iwd/iwd_1.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/iwd/iwd_1.12.bb')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_1.12.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.12.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.12.bb
new file mode 100644
index 000000000..ccdc65ac6
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iwd/iwd_1.12.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Wireless daemon for Linux"
2HOMEPAGE = "https://iwd.wiki.kernel.org/"
3LICENSE = "LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
5
6DEPENDS = "ell"
7
8SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
9 "
10SRCREV = "bde3e0f6e3364e9c884b6b93a944d8138345b8e5"
11S = "${WORKDIR}/git"
12
13inherit autotools manpages pkgconfig python3native systemd
14
15PACKAGECONFIG ??= " \
16 client \
17 monitor \
18 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
19"
20PACKAGECONFIG[client] = "--enable-client,--disable-client,readline"
21PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor"
22PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native"
23PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
24PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
25PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
26
27EXTRA_OECONF = "--enable-external-ell"
28
29SYSTEMD_SERVICE_${PN} = " \
30 iwd.service \
31 ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \
32"
33
34do_configure_prepend() {
35 install -d ${S}/build-aux
36}
37
38do_install_append() {
39 # If client and monitor are disabled, bindir is empty, causing a QA error
40 rmdir --ignore-fail-on-non-empty ${D}/${bindir}
41}
42
43FILES_${PN} += " \
44 ${datadir}/dbus-1 \
45 ${nonarch_libdir}/modules-load.d \
46 ${systemd_unitdir}/network \
47"
48
49RDEPENDS_${PN} = "dbus"
50
51RRECOMMENDS_${PN} = "\
52 kernel-module-pkcs7-message \
53 kernel-module-pkcs8-key-parser \
54 kernel-module-x509-key-parser \
55"