summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb')
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
index efecc64a0..edd4615aa 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
@@ -26,25 +26,25 @@ RDEPENDS_${PN} = "python-core python-audio python-threading python-codecs \
26 python-compiler python-pkgutil python-pydoc python-mmap \ 26 python-compiler python-pkgutil python-pydoc python-mmap \
27 python-netclient python-difflib \ 27 python-netclient python-difflib \
28 python-pprint python-numpy \ 28 python-pprint python-numpy \
29 " 29"
30RDEPENDS_${PN}-grc = "python-pygtk python-lxml python-cheetah" 30RDEPENDS_${PN}-grc = "python-pygtk python-lxml python-cheetah"
31 31
32C_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 32C_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
33 33
34do_configure_prepend() { 34do_configure_prepend() {
35 ${BUILD_CC} ${S}/gr-vocoder/lib/codec2/generate_codebook.c -o ${S}/gr-vocoder/lib/generate_codebook -lm 35 ${BUILD_CC} ${S}/gr-vocoder/lib/codec2/generate_codebook.c -o ${S}/gr-vocoder/lib/generate_codebook -lm
36 echo "ADD_EXECUTABLE(generate_codebook IMPORTED)" >${S}/gr-vocoder/lib/generate_codebook.txt 36 echo "ADD_EXECUTABLE(generate_codebook IMPORTED)" >${S}/gr-vocoder/lib/generate_codebook.txt
37 echo "SET_PROPERTY(TARGET generate_codebook APPEND PROPERTY IMPORTED_CONFIGURATIONS RELEASE)" >>${S}/gr-vocoder/lib/generate_codebook.txt 37 echo "SET_PROPERTY(TARGET generate_codebook APPEND PROPERTY IMPORTED_CONFIGURATIONS RELEASE)" >>${S}/gr-vocoder/lib/generate_codebook.txt
38 echo 'SET_TARGET_PROPERTIES(generate_codebook PROPERTIES IMPORTED_LOCATION_RELEASE "${S}/gr-vocoder/lib/generate_codebook")' >>${S}/gr-vocoder/lib/generate_codebook.txt 38 echo 'SET_TARGET_PROPERTIES(generate_codebook PROPERTIES IMPORTED_LOCATION_RELEASE "${S}/gr-vocoder/lib/generate_codebook")' >>${S}/gr-vocoder/lib/generate_codebook.txt
39} 39}
40 40
41do_compile_prepend() { 41do_compile_prepend() {
42 cp ${S}/gr-vocoder/lib/codec2/defines.h ${OECMAKE_BUILDPATH}/gr-vocoder/lib/codec2 42 cp ${S}/gr-vocoder/lib/codec2/defines.h ${OECMAKE_BUILDPATH}/gr-vocoder/lib/codec2
43} 43}
44 44
45PACKAGES += " \ 45PACKAGES += " \
46 ${PN}-examples \ 46 ${PN}-examples \
47 ${PN}-grc \ 47 ${PN}-grc \
48" 48"
49 49
50FILES_${PN}-grc = "${datadir}/gnuradio/grc" 50FILES_${PN}-grc = "${datadir}/gnuradio/grc"
@@ -57,7 +57,7 @@ FILES_${PN} += "${prefix}/etc/gnuradio/*"
57FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/gnuradio/.debug \ 57FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/gnuradio/.debug \
58 ${PYTHON_SITEPACKAGES_DIR}/gnuradio/*/.debug \ 58 ${PYTHON_SITEPACKAGES_DIR}/gnuradio/*/.debug \
59 ${datadir}/gnuradio/examples/*/.debug \ 59 ${datadir}/gnuradio/examples/*/.debug \
60 " 60"
61FILES_${PN}-examples = "${datadir}/gnuradio/examples" 61FILES_${PN}-examples = "${datadir}/gnuradio/examples"
62 62
63PV = "3.6.4.1" 63PV = "3.6.4.1"
@@ -96,7 +96,7 @@ EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
96 96
97# Only builds for machines with neon instructions. Problem is in upstream cmake. 97# Only builds for machines with neon instructions. Problem is in upstream cmake.
98python () { 98python () {
99 if not oe.utils.contains ('TUNE_FEATURES', 'neon', True, False, d): 99 if not oe.utils.contains ('TUNE_FEATURES', 'neon', True, False, d):
100 raise bb.parse.SkipPackage("'neon' not in TUNE_FEATURES") 100 raise bb.parse.SkipPackage("'neon' not in TUNE_FEATURES")
101} 101}
102 102