summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gnokii/gnokii_0.6.31.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/gnokii/gnokii_0.6.31.bb')
-rw-r--r--meta-oe/recipes-connectivity/gnokii/gnokii_0.6.31.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/gnokii/gnokii_0.6.31.bb b/meta-oe/recipes-connectivity/gnokii/gnokii_0.6.31.bb
new file mode 100644
index 000000000..482645286
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gnokii/gnokii_0.6.31.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Cellphone tools and driver software"
2SECTION = "console/network"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5
6SRC_URI = "http://www.gnokii.org/download/gnokii/gnokii-${PV}.tar.bz2"
7
8DEPENDS = "glib-2.0"
9X11DEPENDS = " libxpm gtk+"
10
11PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
12PACKAGECONFIG[bluez] = "--enable-bluetooth,--disable-bluetooth,bluez4"
13PACKAGECONFIG[libical] = "--enable-libical,--disable-libical,libical"
14PACKAGECONFIG[pcsc-lite] = "--enable-libpcsclite,--disable-libpcsclite,pcsc-lite"
15PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
16PACKAGECONFIG[usb] = "--enable-libusb,--disable-libusb,virtual/libusb0"
17PACKAGECONFIG[x11] = ",--without-x,${X11DEPENDS}"
18
19inherit autotools pkgconfig
20
21PACKAGES += "libgnokii libgnokii-dev"
22
23EXTRA_OECONF = "--disable-smsd"
24
25FILES_${PN} = "${bindir} ${sbindir}"
26FILES_libgnokii-dev = "${includedir} ${libdir}/lib*.so ${libdir}/*.la \
27 ${libdir}/*.a ${libdir}/*.o ${libdir}/pkgconfig \
28 /lib/*.a /lib/*.o ${datadir}/aclocal"
29FILES_${PN}-dev = ""
30FILES_libgnokii = "${libdir}/libgnokii.so.*"
31
32SRC_URI[md5sum] = "d9627f4a1152d3ea7806df4532850d5f"
33SRC_URI[sha256sum] = "8f5a083b05c1a66a3402ca5cd80084e14c2c0632c991bb53b03c78e9adb02501"