summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gateone/gateone_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/gateone/gateone_git.bb')
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone_git.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
new file mode 100644
index 000000000..edc997721
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
@@ -0,0 +1,82 @@
1SUMMARY = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
2LICENSE = "AGPL-3.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428"
4HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne"
5
6PV = "1.2"
7SRCREV = "1528d324088fc1c180b7fdf50f5b5c1af057eef6"
8SRC_URI = "git://github.com/liftoff/GateOne.git \
9 file://0001-configuration.py-Hack-around-broken-gethostname-thin.patch \
10 file://gateone-avahi.service \
11 file://80oe.conf \
12 file://gateone.service \
13 file://gateone-init \
14"
15
16S = "${WORKDIR}/git"
17
18inherit distutils python-dir systemd update-rc.d
19export prefix = "${localstatedir}"
20
21DISTUTILS_INSTALL_ARGS = "--root=${D} \
22 --prefix=${prefix} \
23 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
24 --install-data=${PYTHON_SITEPACKAGES_DIR} \
25 --install-scripts=${bindir} \
26 --skip_init_scripts"
27
28do_install_append() {
29
30 # fix up hardcoded paths
31 sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/gateone.service
32
33 install -d ${D}${systemd_unitdir}/system
34 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
35
36 install -d ${D}${sysconfdir}/init.d
37 install -m 0755 ${WORKDIR}/gateone-init ${D}${sysconfdir}/init.d/gateone
38
39 install -m 0755 -d ${D}${sysconfdir}/avahi/services/
40 install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/
41
42 install -m 0755 -d ${D}${sysconfdir}/gateone/conf.d/
43 install -m 0644 ${WORKDIR}/80oe.conf ${D}${sysconfdir}/gateone/conf.d/80oe.conf
44
45 install -d ${D}${localstatedir}/lib/gateone
46}
47
48FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}"
49RDEPENDS_${PN} = "mime-support \
50 openssh-ssh \
51 python-compression \
52 python-crypt \
53 python-datetime \
54 python-email \
55 python-fcntl \
56 python-futures \
57 python-html \
58 python-imaging \
59 python-io \
60 python-json \
61 python-logging \
62 python-misc \
63 python-multiprocessing \
64 python-netclient \
65 python-pkgutil \
66 python-pyopenssl \
67 python-re \
68 python-readline \
69 python-setuptools \
70 python-shell \
71 python-simplejson \
72 python-subprocess \
73 python-syslog \
74 python-terminal \
75 python-textutils \
76 python-tornado \
77 python-unixadmin \
78 python-xml \
79"
80
81SYSTEMD_SERVICE_${PN} = "gateone.service"
82INITSCRIPT_NAME = "gateone"