summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb')
-rw-r--r--meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
new file mode 100644
index 000000000..0dac7cba3
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
@@ -0,0 +1,55 @@
1SUMMARY = "GNU All Mobile Managment Utilities"
2SECTION = "console/network"
3DEPENDS = "cmake-native virtual/libiconv libdbi mysql5 glib-2.0 udev"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a17cb0a873d252440acfdf9b3d0e7fbf"
6HOMEPAGE = "http://www.gammu.org/"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}/${PV}/${BP}.tar.bz2 \
9 file://gammurc \
10 file://gammu-smsdrc \
11"
12
13SRC_URI[md5sum] = "8ea16c6b3cc48097a8e62311fe0e25b9"
14SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797968fc3"
15
16inherit distutils cmake gettext
17
18do_install_append() {
19 # these files seem to only be used by symbian and trigger QA warnings
20 rm -rf ${D}/usr/share/gammu
21 #install default configuration files
22 install -d ${D}${sysconfdir}
23 install -m 0644 ${WORKDIR}/gammurc ${D}${sysconfdir}/gammurc
24 install -m 0644 ${WORKDIR}/gammu-smsdrc ${D}${sysconfdir}/gammu-smsdrc
25}
26
27EXTRA_OECONF = " \
28 --enable-shared \
29 --enable-backup \
30 --enable-protection \
31"
32
33EXTRA_OECMAKE = " \
34 -DWITH_CURL=OFF \
35 -DWITH_BLUETOOTH=OFF \
36 -DWITH_NOKIA_SUPPORT=OFF \
37 -DWITH_IRDA=OFF \
38 -DWITH_PYTHON=OFF \
39 -DWITH_MySQL=ON \
40 -DWITH_Postgres=OFF \
41"
42
43PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}"
44
45FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu \
46 ${bindir}/gammu-detect ${sysconfdir}/gammurc"
47CONFFILES_${PN} = "${sysconfdir}/gammurc"
48FILES_${PN}-smsd = "${bindir}/gammu-smsd* ${sysconfdir}/gammu-smsdrc"
49CONFFILES_${PN}-smsd = "${sysconfdir}/gammu-smsdrc"
50FILES_${PN}-dev += "${bindir}/gammu-config ${libdir}/*.so"
51FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug ${PYTHON_SITEPACKAGES_DIR}/gammu/.debug"
52FILES_libgammu = "${libdir}/libGammu.so.*"
53FILES_libgsmsd = "${libdir}/libgsmsd.so.*"
54FILES_python-${PN} = "${PYTHON_SITEPACKAGES_DIR}/gammu/*.??"
55