summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/pmbw/pmbw_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/pmbw/pmbw_git.bb b/meta-oe/recipes-benchmark/pmbw/pmbw_git.bb
new file mode 100644
index 000000000..7a69395f7
--- /dev/null
+++ b/meta-oe/recipes-benchmark/pmbw/pmbw_git.bb
@@ -0,0 +1,28 @@
1SUMMERY = "Parallel Memory Bandwidth Measurement / Benchmark"
2DESCRIPTION = "\
3The tool pmbw is a set of assembler routines to measure the parallel memory \
4(cache and RAM) bandwidth of modern multi-core machines."
5HOMEPAGE = "http://panthema.net/2013/pmbw/"
6SECTION = "benchmark/tests"
7AUTHOR = "Timo Bingmann"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "git://github.com/bingmann/pmbw;protocol=https"
12
13PV = "0.6.2+git${SRCPV}"
14SRCREV = "4a3b37728060a8aba06fc83f157a1965088d79d6"
15
16S = "${WORKDIR}/git"
17
18inherit autotools
19
20# the hand coded asm uses r11, which therefore cannot be used for storing
21# the frame pointer when debugging on arm
22SELECTED_OPTIMIZATION_remove_arm = "-fno-omit-frame-pointer"
23
24PACKAGES =+ "${PN}-stats2gnuplot"
25
26FILES_${PN}-stats2gnuplot = "${bindir}/stats2gnuplot"
27
28RRECOMMENDS_${PN} = "${PN}-stats2gnuplot"