summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorStefan Müller-Klieser <s.mueller-klieser@phytec.de>2016-12-18 18:49:28 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:24:53 +0100
commit9c72933e10706d675b667194109fba5109d32858 (patch)
tree15e797efb35731028994870cc6661e462dae5f28 /meta-oe/recipes-benchmark
parent0df6263bf65ee632d2edf22e7ee69362e0518275 (diff)
downloadmeta-openembedded-9c72933e10706d675b667194109fba5109d32858.tar.gz
pmbw: add recipe for ram benchmarks
This adds the Parallel Memory Bandwidth Benchmark tool to the layer. It consists of a collection of assembly routines for testing cache and memory access performance. It also contains a converter to generate gnuplot scripts for the results. Signed-off-by: Stefan Müller-Klieser <s.mueller-klieser@phytec.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/pmbw/pmbw_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/pmbw/pmbw_git.bb b/meta-oe/recipes-benchmark/pmbw/pmbw_git.bb
new file mode 100644
index 000000000..7a69395f7
--- /dev/null
+++ b/meta-oe/recipes-benchmark/pmbw/pmbw_git.bb
@@ -0,0 +1,28 @@
1SUMMERY = "Parallel Memory Bandwidth Measurement / Benchmark"
2DESCRIPTION = "\
3The tool pmbw is a set of assembler routines to measure the parallel memory \
4(cache and RAM) bandwidth of modern multi-core machines."
5HOMEPAGE = "http://panthema.net/2013/pmbw/"
6SECTION = "benchmark/tests"
7AUTHOR = "Timo Bingmann"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "git://github.com/bingmann/pmbw;protocol=https"
12
13PV = "0.6.2+git${SRCPV}"
14SRCREV = "4a3b37728060a8aba06fc83f157a1965088d79d6"
15
16S = "${WORKDIR}/git"
17
18inherit autotools
19
20# the hand coded asm uses r11, which therefore cannot be used for storing
21# the frame pointer when debugging on arm
22SELECTED_OPTIMIZATION_remove_arm = "-fno-omit-frame-pointer"
23
24PACKAGES =+ "${PN}-stats2gnuplot"
25
26FILES_${PN}-stats2gnuplot = "${bindir}/stats2gnuplot"
27
28RRECOMMENDS_${PN} = "${PN}-stats2gnuplot"