summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_7.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_7.4.0.bb')
-rw-r--r--meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_7.4.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_7.4.0.bb b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_7.4.0.bb
new file mode 100644
index 000000000..3ccd5db44
--- /dev/null
+++ b/meta-oe/recipes-benchmark/phoronix-test-suite/phoronix-test-suite_7.4.0.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Phoronix Test Suite"
2DESCRIPTION = "The Phoronix Test Suite is designed to carry out both qualitative \
3and quantitative benchmarks in a clean, reproducible, and easy-to-use manner."
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6SECTION = "console/tests"
7
8SRC_URI = "http://www.phoronix-test-suite.com/releases/${BP}.tar.gz"
9SRC_URI[md5sum] = "86fa3eede43ffff88992fe21368b11b7"
10SRC_URI[sha256sum] = "de9aec3ef4f980581756fd0bf7b30dd1ccb20e7aae637078a587606bf75a6b67"
11
12S = "${WORKDIR}/phoronix-test-suite"
13
14inherit systemd allarch
15
16do_install() {
17 DESTDIR=${D} ./install-sh ${exec_prefix}
18
19 if [ "${systemd_unitdir}" != "/usr/lib/systemd" ]; then
20 install -d ${D}/${systemd_unitdir}/system/
21 mv ${D}/usr/lib/systemd/system/* ${D}/${systemd_unitdir}/system/
22 rm -rf ${D}/usr/lib/
23 fi
24}
25
26SYSTEMD_SERVICE_${PN} = "phoromatic-client.service phoromatic-server.service"
27RDEPENDS_${PN} += "bash python php-cli"
28
29FILES_${PN} += " \
30 ${datadir}/phoronix-test-suite \
31 ${datadir}/appdata/phoronix-test-suite.appdata.xml \
32 ${datadir}/icons/hicolor/48x48/apps/phoronix-test-suite.png \
33 ${datadir}/icons/hicolor/64x64/mimetypes/application-x-openbenchmarking.png \
34 ${datadir}/mime/packages/openbenchmarking-mime.xml \
35 ${systemd_unitdir}/* \
36"