summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb')
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
new file mode 100644
index 000000000..24cd0b0ea
--- /dev/null
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
@@ -0,0 +1,78 @@
1SUMMARY = "Tools for performance analysis"
2HOMEPAGE = "http://lmbench.sourceforge.net/"
3SECTION = "console/utils"
4LICENSE = "GPLv2 & GPL-2.0-with-lmbench-restriction"
5LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
6 file://COPYING-2;md5=8e9aee2ccc75d61d107e43794a25cdf9"
7
8inherit autotools-brokensep
9
10PR = "r2"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
13 file://lmbench-run \
14 file://rename-line-binary.patch \
15 file://update-results-script.patch \
16 file://obey-ranlib.patch \
17 file://update-config-script.patch \
18 file://use-base_libdir-instead-of-hardcoded-lib.patch \
19 file://lmbench_result_html_report.patch \
20 file://fix-lmbench-memory-check-failure.patch \
21"
22SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
23SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
24
25EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" RANLIB="${RANLIB}" CFLAGS="${CFLAGS}" \
26 LDFLAGS="${LDFLAGS}" LD="${LD}" OS="${TARGET_SYS}" \
27 TARGET="${TARGET_OS}" BASE="${prefix}" MANDIR="${mandir}"'
28
29do_configure() {
30 :
31}
32
33do_compile () {
34 . ${CONFIG_SITE}
35 if [ X"$ac_cv_uint" = X"yes" ]; then
36 CFLAGS="${CFLAGS} -DHAVE_uint"
37 fi
38 install -d ${S}/bin/${TARGET_SYS}
39 oe_runmake -C src
40}
41
42do_install () {
43 install -d ${D}${sysconfdir}/default/volatiles \
44 ${D}${bindir} ${D}${mandir} ${D}${libdir}/lmbench \
45 ${D}${datadir}/lmbench/scripts
46
47 echo "d root root 0755 ${localstatedir}/run/${BPN} none" \
48 > ${D}${sysconfdir}/default/volatiles/99_lmbench
49 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
50 install -d ${D}${sysconfdir}/tmpfiles.d
51 echo "d /run/${BPN} - - - -" \
52 > ${D}${sysconfdir}/tmpfiles.d/lmbench.conf
53 fi
54
55 oe_runmake BASE="${D}${prefix}" MANDIR="${D}${mandir}" \
56 -C src install
57 mv ${D}${bindir}/line ${D}${bindir}/lm_line
58 install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/
59 sed -i -e 's,^SHAREDIR=.*$,SHAREDIR=${datadir}/${BPN},;' \
60 -e 's,^BINDIR=.*$,BINDIR=${libdir}/${BPN},;' \
61 -e 's,^CONFIG=.*$,CONFIG=`$SCRIPTSDIR/config`,;' \
62 ${D}${bindir}/lmbench-run
63 install -m 0755 ${S}/scripts/lmbench ${D}${bindir}
64 install -m 0755 ${S}/scripts/* ${D}${datadir}/lmbench/scripts
65}
66
67pkg_postinst_${PN} () {
68 if [ -z "$D" ]; then
69 if command -v systemd-tmpfiles >/dev/null; then
70 systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/lmbench.conf
71 elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
72 ${sysconfdir}/init.d/populate-volatile.sh update
73 fi
74 fi
75}
76
77RDEPENDS_${PN} = "perl"
78FILES_${PN} += "${datadir}/lmbench ${libdir}/lmbench"