summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb20
1 files changed, 5 insertions, 15 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 14c909e75..66fd8e21d 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -3,14 +3,14 @@ HOMEPAGE = "https://github.com/libhugetlbfs/libhugetlbfs"
3LICENSE = "LGPLv2.1" 3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1" 4LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1"
5 5
6DEPENDS = "sysfsutils perl" 6DEPENDS = "sysfsutils"
7RDEPENDS_${PN} += "bash perl python python-io python-lang python-subprocess python-resource ${PN}-perl" 7RDEPENDS_${PN} += "bash python python-io python-lang python-subprocess python-resource"
8RDEPENDS_${PN}-tests += "bash" 8RDEPENDS_${PN}-tests += "bash"
9 9
10PV = "2.20" 10PV = "2.21"
11PE = "1" 11PE = "1"
12 12
13SRCREV = "e44180072b796c0e28e53c4d01ef6279caaa2a99" 13SRCREV = "73d06e69108f231696e9c5c44f4b42690fc5d752"
14SRC_URI = " \ 14SRC_URI = " \
15 git://github.com/libhugetlbfs/libhugetlbfs.git;protocol=https \ 15 git://github.com/libhugetlbfs/libhugetlbfs.git;protocol=https \
16 file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \ 16 file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \
@@ -18,7 +18,6 @@ SRC_URI = " \
18 file://tests-Makefile-install-static-4G-edge-testcases.patch \ 18 file://tests-Makefile-install-static-4G-edge-testcases.patch \
19 file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \ 19 file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \
20 file://libhugetlbfs-elf_i386-avoid-search-host-library-path.patch \ 20 file://libhugetlbfs-elf_i386-avoid-search-host-library-path.patch \
21 file://Force-text-segment-alignment-to-0x08000000-for-i386-.patch \
22 file://0001-include-stddef.h-for-ptrdiff_t.patch \ 21 file://0001-include-stddef.h-for-ptrdiff_t.patch \
23 file://0002-Mark-glibc-specific-code-so.patch \ 22 file://0002-Mark-glibc-specific-code-so.patch \
24 file://0003-alloc.c-Avoid-sysconf-_SC_LEVEL2_CACHE_LINESIZE-on-l.patch \ 23 file://0003-alloc.c-Avoid-sysconf-_SC_LEVEL2_CACHE_LINESIZE-on-l.patch \
@@ -51,14 +50,6 @@ do_configure() {
51 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'ld-is-gold', d)}" ]; then 50 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'ld-is-gold', d)}" ]; then
52 sed -i 's/CUSTOM_LDSCRIPTS = yes/CUSTOM_LDSCRIPTS = no/' Makefile 51 sed -i 's/CUSTOM_LDSCRIPTS = yes/CUSTOM_LDSCRIPTS = no/' Makefile
53 fi 52 fi
54
55 # fixup perl module directory hardcoded to perl5
56 sed -i 's/perl5/perl/g' Makefile
57
58 # fixup to install perl module under $(LIBDIR)/perl/${@get_perl_version(d)}/TLBC
59 # to avoid below error
60 # Can't locate TLBC/OpCollect.pm in @INC
61 sed -i '/^PMDIR/ s:perl:perl/${@get_perl_version(d)}:g' Makefile
62} 53}
63 54
64do_install() { 55do_install() {
@@ -69,11 +60,10 @@ do_install() {
69} 60}
70 61
71 62
72PACKAGES =+ "${PN}-perl ${PN}-tests " 63PACKAGES =+ "${PN}-tests "
73FILES_${PN} += "${libdir}/*.so" 64FILES_${PN} += "${libdir}/*.so"
74FILES_${PN}-dev = "${includedir}" 65FILES_${PN}-dev = "${includedir}"
75FILES_${PN}-dbg += "${libdir}/libhugetlbfs/tests/obj32/.debug ${libdir}/libhugetlbfs/tests/obj64/.debug" 66FILES_${PN}-dbg += "${libdir}/libhugetlbfs/tests/obj32/.debug ${libdir}/libhugetlbfs/tests/obj64/.debug"
76FILES_${PN}-perl = "${libdir}/perl"
77FILES_${PN}-tests += "${libdir}/libhugetlbfs/tests" 67FILES_${PN}-tests += "${libdir}/libhugetlbfs/tests"
78 68
79INSANE_SKIP_${PN} = "dev-so" 69INSANE_SKIP_${PN} = "dev-so"