summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch
new file mode 100644
index 000000000..215ae728d
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch
@@ -0,0 +1,34 @@
1Subject: [PATCH] aarch64: fix cross compilation
2
3This patch allow to override CC and use it for aarch64 case like
4the other architectures.
5
6Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
7
8Upstream-Status: Submitted
9---
10 Makefile | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/Makefile b/Makefile
14index 91502e1..5aa1e12 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -33,7 +33,7 @@ CFLAGS += -Wall -fPIC
18 CPPFLAGS += -D__LIBHUGETLBFS__
19
20 ARCH = $(shell uname -m | sed -e s/i.86/i386/)
21-CC = gcc
22+CC ?= gcc
23
24 CUSTOM_LDSCRIPTS = yes
25
26@@ -66,7 +66,7 @@ ELF32 += armelf_linux_eabi
27 CUSTOM_LDSCRIPTS = no
28 else
29 ifneq (,$(findstring aarch64,$(ARCH)))
30-CC64 = gcc
31+CC64 = $(CC)
32 ELF64 = aarch64elf
33 TMPLIB64 = lib64
34 CUSTOM_LDSCRIPTS = no