summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/fio/fio_3.36.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/fio/fio_3.36.bb')
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_3.36.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.36.bb b/meta-oe/recipes-benchmark/fio/fio_3.36.bb
new file mode 100644
index 000000000..a871ed8fe
--- /dev/null
+++ b/meta-oe/recipes-benchmark/fio/fio_3.36.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Filesystem and hardware benchmark and stress tool"
2DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
3stress/hardware verification. It has support for a number of I/O engines, \
4I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
5and much more. It can work on block devices as well as files. fio accepts \
6job descriptions in a simple-to-understand text format. Several example job \
7files are included. fio displays all sorts of I/O performance information."
8HOMEPAGE = "http://freecode.com/projects/fio"
9SECTION = "console/tests"
10LICENSE = "GPL-2.0-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13DEPENDS = "libaio zlib coreutils-native"
14DEPENDS += "${@bb.utils.contains('MACHINE_FEATURES', 'pmem', 'pmdk', '', d)}"
15RDEPENDS:${PN} = "python3-core bash"
16
17PACKAGECONFIG_NUMA = "numa"
18# ARM does not currently support NUMA
19PACKAGECONFIG_NUMA:arm = ""
20PACKAGECONFIG_NUMA:armeb = ""
21
22PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
23PACKAGECONFIG[numa] = ",--disable-numa,numactl"
24
25PV .= "+git"
26SRCREV = "b2403d413ee734e8835539319d8bc3429a0777ac"
27SRC_URI = "git://git.kernel.dk/fio.git;branch=master"
28
29S = "${WORKDIR}/git"
30
31# avoids build breaks when using no-static-libs.inc
32DISABLE_STATIC = ""
33
34EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
35EXTRA_OECONF = "${@bb.utils.contains('MACHINE_FEATURES', 'x86', '--disable-optimizations', '', d)}"
36
37do_configure() {
38 ./configure ${EXTRA_OECONF}
39}
40
41do_install() {
42 oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
43 install -d ${D}/${docdir}/${PN}
44 cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/
45}