summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03e.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/bonnie/bonnie++_1.03e.bb')
-rw-r--r--meta-oe/recipes-benchmark/bonnie/bonnie++_1.03e.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03e.bb b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03e.bb
new file mode 100644
index 000000000..2c1217e34
--- /dev/null
+++ b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03e.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Tests large file IO and creation/deletion of small files"
2HOMEPAGE = "http://www.coker.com.au/bonnie++/"
3SECTION = "benchmark/tests"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0"
6
7SRC_URI = "http://www.coker.com.au/bonnie++/${BPN}-${PV}.tgz \
8 file://gcc-4.3-fixes.patch \
9"
10SRC_URI[md5sum] = "750aa5b5051263a99c6c195888c74968"
11SRC_URI[sha256sum] = "cb3866116634bf65760b6806be4afa7e24a1cad6f145c876df8721f01ba2e2cb"
12
13inherit autotools-brokensep
14
15SCRIPTS = "bon_csv2html bon_csv2txt"
16EXES = "bonnie++ zcav"
17
18TARGET_CC_ARCH += "${LDFLAGS}"
19
20do_install () {
21 install -d ${D}/${bindir}
22 install -d ${D}/${sbindir}
23 install -m 0755 ${EXES} ${D}/${sbindir}
24 install -m 0755 ${SCRIPTS} ${D}/${bindir}
25}
26
27PACKAGES =+ "bonnie-scripts"
28
29FILES_${PN} = "${sbindir}"
30FILES_bonnie-scripts = "${bindir}"
31
32RDEPENDS_bonnie-scripts += "perl"