diff options
Diffstat (limited to 'meta-oe/dynamic-layers/meta-python/recipes-connectivity/thingsboard-gateway/thingsboard-gateway_3.5.1.bb')
-rw-r--r-- | meta-oe/dynamic-layers/meta-python/recipes-connectivity/thingsboard-gateway/thingsboard-gateway_3.5.1.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/thingsboard-gateway/thingsboard-gateway_3.5.1.bb b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/thingsboard-gateway/thingsboard-gateway_3.5.1.bb new file mode 100644 index 000000000..7f2859186 --- /dev/null +++ b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/thingsboard-gateway/thingsboard-gateway_3.5.1.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | SUMMARY = "Open-source IoT platform for data collection, processing, visualization, and device management" | ||
2 | DESCRIPTION = "\ | ||
3 | The Thingsboard IoT Gateway is an open-source solution that allows you \ | ||
4 | to integrate devices connected to legacy and third-party systems with Thingsboard." | ||
5 | HOMEPAGE = "https://thingsboard.io/" | ||
6 | |||
7 | LICENSE = "Apache-2.0" | ||
8 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" | ||
9 | |||
10 | SRC_URI[sha256sum] = "3d4ae3026b76be94aef67eba7d7e3a64e436ba9556d74ad142ba8988e4e4b253" | ||
11 | |||
12 | inherit pypi setuptools3 | ||
13 | |||
14 | PYPI_PACKAGE = "thingsboard-gateway" | ||
15 | |||
16 | RDEPENDS:${PN} += " python3-jsonpath-rw \ | ||
17 | python3-regex \ | ||
18 | python3-paho-mqtt \ | ||
19 | python3-pyyaml \ | ||
20 | python3-simplejson \ | ||
21 | python3-requests \ | ||
22 | python3-pip \ | ||
23 | python3-pyrsistent \ | ||
24 | " | ||
25 | |||
26 | SRC_URI += "file://bacnet.json \ | ||
27 | file://ble.json \ | ||
28 | file://can.json \ | ||
29 | file://custom_serial.json \ | ||
30 | file://modbus.json \ | ||
31 | file://modbus_serial.json \ | ||
32 | file://mqtt.json \ | ||
33 | file://opcua.json \ | ||
34 | file://odbc.json \ | ||
35 | file://request.json \ | ||
36 | file://rest.json \ | ||
37 | file://snmp.json \ | ||
38 | file://tb_gateway.yaml \ | ||
39 | file://logs.conf \ | ||
40 | file://thingsboard-gateway.service \ | ||
41 | " | ||
42 | |||
43 | |||
44 | inherit systemd | ||
45 | |||
46 | SYSTEMD_PACKAGES = "${PN}" | ||
47 | SYSTEMD_SERVICE:${PN} = "thingsboard-gateway.service" | ||
48 | |||
49 | FILES:${PN} += "/etc \ | ||
50 | /lib \ | ||
51 | /usr \ | ||
52 | " | ||
53 | |||
54 | do_install:append(){ | ||
55 | |||
56 | install -d ${D}${sysconfdir}/thingsboard-gateway/config | ||
57 | |||
58 | for file in $(find ${UNPACKDIR} -maxdepth 1 -type f -name *.json); do | ||
59 | install -m 0644 "$file" ${D}${sysconfdir}/thingsboard-gateway/config | ||
60 | done | ||
61 | |||
62 | install -m 0644 ${UNPACKDIR}/tb_gateway.yaml ${D}${sysconfdir}/thingsboard-gateway/config | ||
63 | install -m 0644 ${UNPACKDIR}/logs.conf ${D}${sysconfdir}/thingsboard-gateway/config | ||
64 | |||
65 | install -d ${D}${systemd_unitdir}/system/ | ||
66 | install -m 0644 ${UNPACKDIR}/thingsboard-gateway.service ${D}${systemd_system_unitdir}/thingsboard-gateway.service | ||
67 | } | ||