diff options
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/snort/snort3/0001-cmake-Check-for-HP-libunwind.patch | 33 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/snort/snort3_git.bb | 3 |
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/snort/snort3/0001-cmake-Check-for-HP-libunwind.patch b/meta-networking/recipes-connectivity/snort/snort3/0001-cmake-Check-for-HP-libunwind.patch new file mode 100644 index 0000000000..7b7a0d098f --- /dev/null +++ b/meta-networking/recipes-connectivity/snort/snort3/0001-cmake-Check-for-HP-libunwind.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 433a412fad2ab0383ac3c625d183a71684f2b97b Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 20 Feb 2024 15:35:14 -0800 | ||
4 | Subject: [PATCH] cmake: Check for HP libunwind | ||
5 | |||
6 | This is to ensure that cmake does not detect LLVM unwinder, which | ||
7 | can provide the support for some HP unwinder functionality but not all | ||
8 | e.g. unw_strerror goes missing. By checking for libunwind-common.h in | ||
9 | tests we ensure that this test passes only with HP libunwind. | ||
10 | |||
11 | Upstream-Status: Inappropriate [OE-Specific] | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | cmake/FindLibunwind.cmake | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/cmake/FindLibunwind.cmake b/cmake/FindLibunwind.cmake | ||
19 | index f66800a18..1ad66fc83 100644 | ||
20 | --- a/cmake/FindLibunwind.cmake | ||
21 | +++ b/cmake/FindLibunwind.cmake | ||
22 | @@ -22,7 +22,7 @@ find_package(PkgConfig QUIET) | ||
23 | pkg_check_modules(PC_LIBUNWIND libunwind) | ||
24 | |||
25 | find_path(LIBUNWIND_INCLUDE_DIRS | ||
26 | - NAMES libunwind.h | ||
27 | + NAMES libunwind-common.h | ||
28 | HINTS ${PC_LIBUNWIND_INCLUDE_DIRS} | ||
29 | ) | ||
30 | |||
31 | -- | ||
32 | 2.43.2 | ||
33 | |||
diff --git a/meta-networking/recipes-connectivity/snort/snort3_git.bb b/meta-networking/recipes-connectivity/snort/snort3_git.bb index f40a1d7d6f..0f4a86f61e 100644 --- a/meta-networking/recipes-connectivity/snort/snort3_git.bb +++ b/meta-networking/recipes-connectivity/snort/snort3_git.bb | |||
@@ -9,7 +9,8 @@ PV = "3+git${SRCPV}" | |||
9 | 9 | ||
10 | DEPENDS = "flex hwloc libdaq libdnet libpcap libpcre libtirpc libunwind luajit zlib" | 10 | DEPENDS = "flex hwloc libdaq libdnet libpcap libpcre libtirpc libunwind luajit zlib" |
11 | 11 | ||
12 | SRC_URI = "git://github.com/snort3/snort3.git;protocol=https;branch=master" | 12 | SRC_URI = "git://github.com/snort3/snort3.git;protocol=https;branch=master \ |
13 | file://0001-cmake-Check-for-HP-libunwind.patch" | ||
13 | SRCREV = "e1760a8dbb829bb3fcf1a340ab6cc4bb80a47ecd" | 14 | SRCREV = "e1760a8dbb829bb3fcf1a340ab6cc4bb80a47ecd" |
14 | 15 | ||
15 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |