summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/ncftp/ncftp/ncftp-configure-use-BUILD_CC-for-ccdv.patch32
-rw-r--r--meta-networking/recipes-daemons/ncftp/ncftp_3.2.5.bb7
2 files changed, 38 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/ncftp/ncftp/ncftp-configure-use-BUILD_CC-for-ccdv.patch b/meta-networking/recipes-daemons/ncftp/ncftp/ncftp-configure-use-BUILD_CC-for-ccdv.patch
new file mode 100644
index 000000000..aa590175c
--- /dev/null
+++ b/meta-networking/recipes-daemons/ncftp/ncftp/ncftp-configure-use-BUILD_CC-for-ccdv.patch
@@ -0,0 +1,32 @@
1From 043e1a9ec83a59671ef8c4cad679dbf781e5ef98 Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Sun, 29 Nov 2015 23:37:06 -0800
4Subject: [PATCH] configure: use BUILD_CC for ccdv
5
6ccdv is intended to be invoked from Makefiles only,
7it doesn't work for the cross compiling, so compile
8it with $BUILD_CC and corresponding CFLAGS.
9
10Upstream-Status: Inappropriate [cross compile specific]
11
12Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
13---
14 configure | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/configure b/configure
18index 2f0fae0..a7e9112 100755
19--- a/configure
20+++ b/configure
21@@ -11286,7 +11286,7 @@ panic:
22 } /* main */
23 /* eof ccdv.c */
24 EOF
25- ${CC-cc} $DEFS $CPPFLAGS $CFLAGS "ccdv.c" -o "ccdv" >/dev/null 2>&1
26+ ${BUILD_CC} $DEFS ${BUILD_CPPFLAGS} ${BUILD_CFLAGS} "ccdv.c" -o "ccdv" >/dev/null 2>&1
27 rm -f ccdv.c ccdv.o ccdv.c.gz.uu ccdv.c.gz
28 strip ./ccdv >/dev/null 2>&1
29 ./ccdv >/dev/null 2>&1
30--
312.3.5
32
diff --git a/meta-networking/recipes-daemons/ncftp/ncftp_3.2.5.bb b/meta-networking/recipes-daemons/ncftp/ncftp_3.2.5.bb
index 40b59a436..893eacb99 100644
--- a/meta-networking/recipes-daemons/ncftp/ncftp_3.2.5.bb
+++ b/meta-networking/recipes-daemons/ncftp/ncftp_3.2.5.bb
@@ -5,12 +5,17 @@ LICENSE = "ClArtistic"
5LIC_FILES_CHKSUM = "file://ncftp/cmds.c;beginline=3;endline=4;md5=9de76faeaedc4f908082e3f8142715f4" 5LIC_FILES_CHKSUM = "file://ncftp/cmds.c;beginline=3;endline=4;md5=9de76faeaedc4f908082e3f8142715f4"
6DEPENDS = "ncurses" 6DEPENDS = "ncurses"
7 7
8SRC_URI = "${DEBIAN_MIRROR}/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz" 8SRC_URI = "${DEBIAN_MIRROR}/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz \
9 file://ncftp-configure-use-BUILD_CC-for-ccdv.patch \
10"
9SRC_URI[md5sum] = "685e45f60ac11c89442c572c28af4228" 11SRC_URI[md5sum] = "685e45f60ac11c89442c572c28af4228"
10SRC_URI[sha256sum] = "ac111b71112382853b2835c42ebe7bd59acb7f85dd00d44b2c19fbd074a436c4" 12SRC_URI[sha256sum] = "ac111b71112382853b2835c42ebe7bd59acb7f85dd00d44b2c19fbd074a436c4"
11 13
12inherit autotools-brokensep pkgconfig 14inherit autotools-brokensep pkgconfig
13 15
16PACKAGECONFIG ??= ""
17PACKAGECONFIG[ccdv] = "--enable-ccdv,--disable-ccdv,,"
18
14do_configure() { 19do_configure() {
15 oe_runconf 20 oe_runconf
16} 21}