summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/dhcpcd/dhcpcd_9.1.4.bb29
-rw-r--r--meta-networking/recipes-connectivity/dhcpcd/files/0001-remove-INCLUDEDIR-to-prevent-build-issues.patch45
-rw-r--r--meta-networking/recipes-connectivity/dhcpcd/files/0002-Fix-compile-without-IPv6-on-systems-that-do-not-define-ALIGN.patch34
3 files changed, 0 insertions, 108 deletions
diff --git a/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_9.1.4.bb b/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_9.1.4.bb
deleted file mode 100644
index 766df3a2b..000000000
--- a/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_9.1.4.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1SECTION = "console/network"
2SUMMARY = "dhcpcd - a DHCP client"
3DESCRIPTION = "dhcpcd runs on your machine and silently configures your \
4 computer to work on the attached networks without trouble \
5 and mostly without configuration."
6
7HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=9674cc803c5d71306941e6e8b5c002f2"
11
12UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
13
14SRC_URI = "http://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
15 file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
16 file://0002-Fix-compile-without-IPv6-on-systems-that-do-not-define-ALIGN.patch"
17
18SRC_URI[sha256sum] = "5fe133e5497d8af6d26bd6e6b8dd48ab12d124d6cc4cefe6de6536ff97f76820"
19
20inherit pkgconfig autotools-brokensep
21
22PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
23
24PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev"
25PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
26
27EXTRA_OECONF = "--enable-ipv4"
28
29FILES_${PN}-dbg += "${libdir}/dhcpcd/dev/.debug"
diff --git a/meta-networking/recipes-connectivity/dhcpcd/files/0001-remove-INCLUDEDIR-to-prevent-build-issues.patch b/meta-networking/recipes-connectivity/dhcpcd/files/0001-remove-INCLUDEDIR-to-prevent-build-issues.patch
deleted file mode 100644
index 37d234443..000000000
--- a/meta-networking/recipes-connectivity/dhcpcd/files/0001-remove-INCLUDEDIR-to-prevent-build-issues.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From aa9e3982c1e75ad49945a62f5e262279c7a905a4 Mon Sep 17 00:00:00 2001
2From: Stefano Cappa <stefano.cappa.ks89@gmail.com>
3Date: Sun, 13 Jan 2019 01:50:52 +0100
4Subject: [PATCH] remove INCLUDEDIR to prevent build issues
5
6Upstream-Status: Pending
7
8Signed-off-by: Stefano Cappa <stefano.cappa.ks89@gmail.com>
9---
10 configure | 5 -----
11 1 file changed, 5 deletions(-)
12
13diff --git a/configure b/configure
14index 6c81e0db..32dea2b4 100755
15--- a/configure
16+++ b/configure
17@@ -20,7 +20,6 @@ BUILD=
18 HOST=
19 HOSTCC=
20 TARGET=
21-INCLUDEDIR=
22 DEBUG=
23 FORK=
24 STATIC=
25@@ -72,7 +71,6 @@ for x do
26 --mandir) MANDIR=$var;;
27 --datadir) DATADIR=$var;;
28 --with-ccopts|CFLAGS) CFLAGS=$var;;
29- -I|--includedir) INCLUDEDIR="$INCLUDEDIR${INCLUDEDIR:+ }-I$var";;
30 CC) CC=$var;;
31 CPPFLAGS) CPPFLAGS=$var;;
32 PKG_CONFIG) PKG_CONFIG=$var;;
33@@ -309,9 +307,6 @@ if [ -n "$CPPFLAGS" ]; then
34 echo "CPPFLAGS=" >>$CONFIG_MK
35 echo "CPPFLAGS+= $CPPFLAGS" >>$CONFIG_MK
36 fi
37-if [ -n "$INCLUDEDIR" ]; then
38- echo "CPPFLAGS+= $INCLUDEDIR" >>$CONFIG_MK
39-fi
40 if [ -n "$LDFLAGS" ]; then
41 echo "LDFLAGS=" >>$CONFIG_MK
42 echo "LDFLAGS+= $LDFLAGS" >>$CONFIG_MK
43--
442.17.2 (Apple Git-113)
45
diff --git a/meta-networking/recipes-connectivity/dhcpcd/files/0002-Fix-compile-without-IPv6-on-systems-that-do-not-define-ALIGN.patch b/meta-networking/recipes-connectivity/dhcpcd/files/0002-Fix-compile-without-IPv6-on-systems-that-do-not-define-ALIGN.patch
deleted file mode 100644
index 2c7f24ebf..000000000
--- a/meta-networking/recipes-connectivity/dhcpcd/files/0002-Fix-compile-without-IPv6-on-systems-that-do-not-define-ALIGN.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 7643b6615aab4de290ead6c1a6b56f10a82bbe6f Mon Sep 17 00:00:00 2001
2From: Roy Marples <roy@marples.name>
3Date: Sat, 4 Jul 2020 13:21:09 +0100
4Subject: [PATCH] Fix compile without IPv6 on systems that do not define ALIGN
5
6Upstream-Status: backport
7
8---
9 src/dhcpcd.h | 5 -----
10 1 file changed, 5 deletions(-)
11
12diff --git a/src/dhcpcd.h b/src/dhcpcd.h
13index 61a6a081..d9719c0a 100644
14--- a/src/dhcpcd.h
15+++ b/src/dhcpcd.h
16@@ -96,7 +96,6 @@ TAILQ_HEAD(if_head, interface);
17
18 #include "privsep.h"
19
20-#ifdef INET6
21 /* dhcpcd requires CMSG_SPACE to evaluate to a compile time constant. */
22 #if defined(__QNX) || \
23 (defined(__NetBSD_Version__) && __NetBSD_Version__ < 600000000)
24@@ -113,10 +112,6 @@ TAILQ_HEAD(if_head, interface);
25 #define CMSG_SPACE(len) (ALIGN(sizeof(struct cmsghdr)) + ALIGN(len))
26 #endif
27
28-#define IP6BUFLEN (CMSG_SPACE(sizeof(struct in6_pktinfo)) + \
29- CMSG_SPACE(sizeof(int)))
30-#endif
31-
32 struct passwd;
33
34 struct dhcpcd_ctx {