summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb/0001-tdb-Add-configure-options-for-packages.patch39
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb_1.4.10.bb (renamed from meta-networking/recipes-support/libtdb/libtdb_1.4.9.bb)2
2 files changed, 33 insertions, 8 deletions
diff --git a/meta-networking/recipes-support/libtdb/libtdb/0001-tdb-Add-configure-options-for-packages.patch b/meta-networking/recipes-support/libtdb/libtdb/0001-tdb-Add-configure-options-for-packages.patch
index 477b1cec7..5c811c468 100644
--- a/meta-networking/recipes-support/libtdb/libtdb/0001-tdb-Add-configure-options-for-packages.patch
+++ b/meta-networking/recipes-support/libtdb/libtdb/0001-tdb-Add-configure-options-for-packages.patch
@@ -21,13 +21,16 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com>
21Rebase to 1.4.9 21Rebase to 1.4.9
22Remove libaio option 22Remove libaio option
23Signed-off-by: Yi Zhao <yi.zhao@windriver.com> 23Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
24
25Rebase to 1.4.10
26Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
24--- 27---
25 lib/replace/wscript | 79 +++++++++++++++++++++++++++++++++------------ 28 lib/replace/wscript | 101 ++++++++++++++++++++++++++++++--------------
26 wscript | 6 ++++ 29 wscript | 6 +++
27 2 files changed, 65 insertions(+), 20 deletions(-) 30 2 files changed, 76 insertions(+), 31 deletions(-)
28 31
29diff --git a/lib/replace/wscript b/lib/replace/wscript 32diff --git a/lib/replace/wscript b/lib/replace/wscript
30index 199e636..cb13b62 100644 33index 77e655b..e6d50b3 100644
31--- a/lib/replace/wscript 34--- a/lib/replace/wscript
32+++ b/lib/replace/wscript 35+++ b/lib/replace/wscript
33@@ -25,6 +25,34 @@ def options(opt): 36@@ -25,6 +25,34 @@ def options(opt):
@@ -103,7 +106,7 @@ index 199e636..cb13b62 100644
103 conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h') 106 conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h')
104 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h') 107 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h')
105 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h') 108 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h')
106@@ -443,20 +481,21 @@ def configure(conf): 109@@ -443,31 +481,32 @@ def configure(conf):
107 110
108 strlcpy_in_bsd = False 111 strlcpy_in_bsd = False
109 112
@@ -112,6 +115,17 @@ index 199e636..cb13b62 100644
112- if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h', 115- if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
113- checklibc=True): 116- checklibc=True):
114- strlcpy_in_bsd = True 117- strlcpy_in_bsd = True
118- elif conf.env.enable_fuzzing:
119- # Just to complicate it more, some versions of Honggfuzz have
120- # got strlcpy and strlcat in libc, but not in <string.h>
121- # (unless it is there coincidentally, on a BSD). Therefore we
122- # can't use CHECK_FUNCS alone to decide whether to add the
123- # headers to replace.h.
124- #
125- # As this is only known to happen on a fuzzing compiler, we'll
126- # skip the check when not in fuzzing mode.
127- conf.CHECK_HEADERS('bsd/string.h')
128-
115- if not conf.CHECK_FUNCS('getpeereid'): 129- if not conf.CHECK_FUNCS('getpeereid'):
116- conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h') 130- conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
117- if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'): 131- if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
@@ -127,6 +141,17 @@ index 199e636..cb13b62 100644
127+ if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h', 141+ if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
128+ checklibc=True): 142+ checklibc=True):
129+ strlcpy_in_bsd = True 143+ strlcpy_in_bsd = True
144+ elif conf.env.enable_fuzzing:
145+ # Just to complicate it more, some versions of Honggfuzz have
146+ # got strlcpy and strlcat in libc, but not in <string.h>
147+ # (unless it is there coincidentally, on a BSD). Therefore we
148+ # can't use CHECK_FUNCS alone to decide whether to add the
149+ # headers to replace.h.
150+ #
151+ # As this is only known to happen on a fuzzing compiler, we'll
152+ # skip the check when not in fuzzing mode.
153+ conf.CHECK_HEADERS('bsd/string.h')
154+
130+ if not conf.CHECK_FUNCS('getpeereid'): 155+ if not conf.CHECK_FUNCS('getpeereid'):
131+ conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h') 156+ conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
132+ if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'): 157+ if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
@@ -140,7 +165,7 @@ index 199e636..cb13b62 100644
140 conf.CHECK_CODE(''' 165 conf.CHECK_CODE('''
141 struct ucred cred; 166 struct ucred cred;
142diff --git a/wscript b/wscript 167diff --git a/wscript b/wscript
143index 5e6a928..5443b43 100644 168index 2c587fb..b2164b2 100644
144--- a/wscript 169--- a/wscript
145+++ b/wscript 170+++ b/wscript
146@@ -69,6 +69,12 @@ def options(opt): 171@@ -69,6 +69,12 @@ def options(opt):
@@ -157,5 +182,5 @@ index 5e6a928..5443b43 100644
157 def configure(conf): 182 def configure(conf):
158 conf.env.disable_tdb_mutex_locking = getattr(Options.options, 183 conf.env.disable_tdb_mutex_locking = getattr(Options.options,
159-- 184--
1602.25.1 1852.34.1
161 186
diff --git a/meta-networking/recipes-support/libtdb/libtdb_1.4.9.bb b/meta-networking/recipes-support/libtdb/libtdb_1.4.10.bb
index 936760035..f23b157e8 100644
--- a/meta-networking/recipes-support/libtdb/libtdb_1.4.9.bb
+++ b/meta-networking/recipes-support/libtdb/libtdb_1.4.10.bb
@@ -15,7 +15,7 @@ SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \
15 file://run-ptest \ 15 file://run-ptest \
16" 16"
17 17
18SRC_URI[sha256sum] = "0ac226073e3a2db8648da7af744cb95f50766a52feeb001d558b2b321b74a765" 18SRC_URI[sha256sum] = "02338e33c16c21c9e29571cef523e76b2b708636254f6f30c6cf195d48c62daf"
19 19
20PACKAGECONFIG ??= "\ 20PACKAGECONFIG ??= "\
21 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \ 21 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \