summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ipsec-tools/ipsec-tools/0002-Don-t-link-against-libfl.patch86
-rw-r--r--meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.1.bb3
2 files changed, 88 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0002-Don-t-link-against-libfl.patch b/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0002-Don-t-link-against-libfl.patch
new file mode 100644
index 000000000..674331dbf
--- /dev/null
+++ b/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0002-Don-t-link-against-libfl.patch
@@ -0,0 +1,86 @@
1From e48b9097dce7bc2bfbb9e9c542124d3b5cebab39 Mon Sep 17 00:00:00 2001
2From: Paul Barker <paul@paulbarker.me.uk>
3Date: Wed, 5 Mar 2014 13:39:14 +0000
4Subject: [PATCH] Don't link against libfl
5
6We can remove all references to yywrap by adding "%option noyywrap" statements
7to each flex source file that doesn't override yywrap. After this, we no longer
8need to link against libfl and so no longer get errors about undefined
9references to yylex.
10
11Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
12Upstream-status: Pending
13---
14 src/libipsec/Makefile.am | 1 -
15 src/racoon/Makefile.am | 2 +-
16 src/racoon/cftoken.l | 2 ++
17 src/setkey/Makefile.am | 1 -
18 src/setkey/token.l | 2 ++
19 5 files changed, 5 insertions(+), 3 deletions(-)
20
21diff --git a/src/libipsec/Makefile.am b/src/libipsec/Makefile.am
22index 6a4e3b3..df1e106 100644
23--- a/src/libipsec/Makefile.am
24+++ b/src/libipsec/Makefile.am
25@@ -26,7 +26,6 @@ libipsec_la_SOURCES = \
26 # version is current:revision:age.
27 # See: http://www.gnu.org/manual/libtool-1.4.2/html_chapter/libtool_6.html#SEC32
28 libipsec_la_LDFLAGS = -version-info 0:1:0
29-libipsec_la_LIBADD = $(LEXLIB)
30
31 noinst_HEADERS = ipsec_strerror.h
32
33diff --git a/src/racoon/Makefile.am b/src/racoon/Makefile.am
34index dbaded9..0662957 100644
35--- a/src/racoon/Makefile.am
36+++ b/src/racoon/Makefile.am
37@@ -38,7 +38,7 @@ racoon_SOURCES = \
38 cftoken.l cfparse.y prsa_tok.l prsa_par.y
39 EXTRA_racoon_SOURCES = isakmp_xauth.c isakmp_cfg.c isakmp_unity.c throttle.c \
40 isakmp_frag.c nattraversal.c security.c $(MISSING_ALGOS)
41-racoon_LDADD = $(CRYPTOBJS) $(HYBRID_OBJS) $(NATT_OBJS) $(FRAG_OBJS) $(LEXLIB) \
42+racoon_LDADD = $(CRYPTOBJS) $(HYBRID_OBJS) $(NATT_OBJS) $(FRAG_OBJS) \
43 $(SECCTX_OBJS) vmbuf.o sockmisc.o misc.o ../libipsec/libipsec.la
44 racoon_DEPENDENCIES = \
45 $(CRYPTOBJS) $(HYBRID_OBJS) $(NATT_OBJS) $(FRAG_OBJS) $(SECCTX_OBJS) \
46diff --git a/src/racoon/cftoken.l b/src/racoon/cftoken.l
47index 490242c..1701922 100644
48--- a/src/racoon/cftoken.l
49+++ b/src/racoon/cftoken.l
50@@ -106,6 +106,8 @@ static int incstackp = 0;
51 static int yy_first_time = 1;
52 %}
53
54+%option noyywrap
55+
56 /* common seciton */
57 nl \n
58 ws [ \t]+
59diff --git a/src/setkey/Makefile.am b/src/setkey/Makefile.am
60index 746c1f1..389e6cf 100644
61--- a/src/setkey/Makefile.am
62+++ b/src/setkey/Makefile.am
63@@ -13,7 +13,6 @@ setkey_SOURCES = \
64
65 setkey_LDFLAGS = ../libipsec/libipsec.la
66 setkey_DEPENDENCIES = ../libipsec/libipsec.la
67-setkey_LDADD = $(LEXLIB)
68
69 noinst_HEADERS = vchar.h extern.h
70 man8_MANS = setkey.8
71diff --git a/src/setkey/token.l b/src/setkey/token.l
72index ad3d843..eb23b76 100644
73--- a/src/setkey/token.l
74+++ b/src/setkey/token.l
75@@ -88,6 +88,8 @@
76 #endif
77 %}
78
79+%option noyywrap
80+
81 /* common section */
82 nl \n
83 ws [ \t]+
84--
851.9.0
86
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.1.bb b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.1.bb
index e93174534..fcf329c11 100644
--- a/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.1.bb
+++ b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.1.bb
@@ -5,10 +5,11 @@ SECTION = "console/network"
5LICENSE = "BSD" 5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://src/libipsec/pfkey.c;beginline=6;endline=31;md5=bc9b7ff40beff19fe6bc6aef26bd2b24" 6LIC_FILES_CHKSUM = "file://src/libipsec/pfkey.c;beginline=6;endline=31;md5=bc9b7ff40beff19fe6bc6aef26bd2b24"
7 7
8DEPENDS = "virtual/kernel openssl readline flex bison-native" 8DEPENDS = "virtual/kernel openssl readline flex-native bison-native"
9 9
10SRC_URI = "ftp://ftp.netbsd.org/pub/NetBSD/misc/ipsec-tools/0.8/ipsec-tools-${PV}.tar.bz2 \ 10SRC_URI = "ftp://ftp.netbsd.org/pub/NetBSD/misc/ipsec-tools/0.8/ipsec-tools-${PV}.tar.bz2 \
11 file://0001-Fix-warning-with-gcc-4.8.patch \ 11 file://0001-Fix-warning-with-gcc-4.8.patch \
12 file://0002-Don-t-link-against-libfl.patch \
12 " 13 "
13SRC_URI[md5sum] = "d38b39f291ba2962387c3232e7335dd8" 14SRC_URI[md5sum] = "d38b39f291ba2962387c3232e7335dd8"
14SRC_URI[sha256sum] = "fa4a95bb36842f001b84c4e7a1bb727e3ee06147edbc830a881d63abe8153dd4" 15SRC_URI[sha256sum] = "fa4a95bb36842f001b84c4e7a1bb727e3ee06147edbc830a881d63abe8153dd4"