summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb')
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb b/meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb
new file mode 100644
index 000000000..683321657
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/wireshark_1.12.4.bb
@@ -0,0 +1,57 @@
1DESCRIPTION = "wireshark - a popular network protocol analyzer"
2HOMEPAGE = "http://www.wireshark.org"
3SECTION = "network"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0"
6
7DEPENDS = "perl-native pcre expat glib-2.0 sbc"
8
9SRC_URI = " \
10 http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-${PV}.tar.bz2 \
11 file://Do-not-set-CC_FOR_BUILD-flags.patch \
12"
13
14PE = "1"
15
16SRC_URI[md5sum] = "acfa156fd35cb66c867b1ace992e4b5b"
17SRC_URI[sha256sum] = "de804e98e252e4b795d28d6ac2d48d7f5aacd9b046ee44d44266983795ebc312"
18
19inherit autotools pkgconfig
20
21ARM_INSTRUCTION_SET = "arm"
22
23# Works with either gtk+ or gtk3.
24WHICH_GTK = "gtk3"
25
26PACKAGECONFIG ??= "libcap gnutls libnl"
27PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}"
28PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
29
30PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_DIR_HOST}, --with-libcap=no, libcap"
31PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
32PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
33PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
34PACKAGECONFIG[gtk2] = "--with-gtk2=yes, --with-gtk2=no, gtk+"
35PACKAGECONFIG[gtk3] = "--with-gtk3=yes, --with-gtk3=no, gtk+3"
36PACKAGECONFIG[graphics] = "--enable-wireshark, --disable-wireshark,"
37PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
38PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
39PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
40PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
41PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua"
42PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib"
43PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
44
45# these next two options require addional layers
46PACKAGECONFIG[adns] = "--with-adns=yes, --with-adns=no, adns"
47PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
48
49EXTRA_OECONF += "--with-qt=no --enable-usr-local=no --enable-tshark --with-pcap=no --enable-pcap-ng-default"
50
51do_configure_prepend() {
52 # force to use fallback
53 sed -i -e '/^glib_prefix/s/=.*$/=""/' ${S}/aclocal-flags
54}
55
56ALLOW_EMPTY_${PN} = "1"
57INHIBIT_PACKAGE_DEBUG_SPLIT = "1"