summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/unbound/unbound_1.19.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/unbound/unbound_1.19.3.bb')
-rw-r--r--meta-networking/recipes-support/unbound/unbound_1.19.3.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/unbound/unbound_1.19.3.bb b/meta-networking/recipes-support/unbound/unbound_1.19.3.bb
new file mode 100644
index 000000000..ffdc78e9d
--- /dev/null
+++ b/meta-networking/recipes-support/unbound/unbound_1.19.3.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Unbound is a validating, recursive, and caching DNS resolver"
2DESCRIPTION = "Unbound's design is a set of modular components which incorporate \
3 features including enhanced security (DNSSEC) validation, Internet Protocol \
4 Version 6 (IPv6), and a client resolver library API as an integral part of the \
5 architecture"
6
7HOMEPAGE = "https://www.unbound.net/"
8SECTION = "net"
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=5308494bc0590c0cb036afd781d78f06"
11
12SRC_URI = "git://github.com/NLnetLabs/unbound.git;protocol=https;branch=branch-1.19.3"
13SRCREV = "48b6c60a24e9a5d6d369a7a37c9fe2a767f26abd"
14
15inherit autotools pkgconfig systemd update-rc.d
16
17DEPENDS = "openssl libtool-native bison-native expat"
18RDEPENDS:${PN} = "bash openssl-bin daemonize"
19
20S = "${WORKDIR}/git"
21
22EXTRA_OECONF = "--with-libexpat=${STAGING_EXECPREFIXDIR} \
23 --with-ssl=${STAGING_EXECPREFIXDIR} \
24 --enable-largefile"
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
27PACKAGECONFIG[dnscrypt] = "--enable-dnscrypt, --disable-dnscrypt, libsodium"
28PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
29PACKAGECONFIG[libevent] = "--with-libevent=${STAGING_EXECPREFIXDIR},,libevent"
30
31do_configure:append() {
32 sed -i -e 's#${RECIPE_SYSROOT}##g' ${B}/config.h
33}
34
35do_install:append() {
36 install -d ${D}${systemd_unitdir}/system
37 install -m 0644 ${B}/contrib/unbound.service ${D}${systemd_unitdir}/system
38
39 install -d ${D}${sysconfdir}/init.d
40 install -m 0755 ${S}/contrib/unbound.init_yocto ${D}${sysconfdir}/init.d/unbound
41}
42
43SYSTEMD_SERVICE:${PN} = "${BPN}.service"
44
45INITSCRIPT_NAME = "unbound"
46INITSCRIPT_PARAMS = "defaults"