diff options
Diffstat (limited to 'meta-networking/recipes-support/tcpreplay')
6 files changed, 19 insertions, 180 deletions
diff --git a/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-cross-compile.patch b/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-cross-compile.patch deleted file mode 100755 index a856b1809..000000000 --- a/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-cross-compile.patch +++ /dev/null | |||
@@ -1,92 +0,0 @@ | |||
1 | Uptream-Status: Pending | ||
2 | |||
3 | Signed-off-by: Zongchun Yu <Zongchun.Yu@freescale.com> | ||
4 | |||
5 | --- a/configure.ac | ||
6 | +++ b/configure.ac | ||
7 | @@ -402,7 +402,6 @@ | ||
8 | |||
9 | dnl 0.9.6 (which is still thinks it is 0.9.5 due to a bug) introduces an important | ||
10 | dnl fix for OSX. See: http://tcpreplay.synfin.net/trac/ticket/167 | ||
11 | -libpcap_version_096=no | ||
12 | AC_RUN_IFELSE(AC_LANG_PROGRAM([[ | ||
13 | #include <string.h> | ||
14 | #include <stdlib.h> | ||
15 | @@ -419,11 +418,12 @@ | ||
16 | exit(0); | ||
17 | |||
18 | exit(1); | ||
19 | -]]), [ | ||
20 | - libpcap_version_096=yes | ||
21 | -]) | ||
22 | +]]), | ||
23 | + [libpcap_version_096=yes], | ||
24 | + [libpcap_version_096=no], | ||
25 | + [libpcap_version_096=yes] | ||
26 | +) | ||
27 | |||
28 | -libpcap_ver8=no | ||
29 | AC_RUN_IFELSE(AC_LANG_PROGRAM([[ | ||
30 | #include <string.h> | ||
31 | #include <stdlib.h> | ||
32 | @@ -444,13 +444,12 @@ | ||
33 | exit(0); | ||
34 | |||
35 | exit(1); | ||
36 | -]]), [ | ||
37 | - libpcap_ver8=yes | ||
38 | -], [ | ||
39 | - libpcap_ver8=no | ||
40 | -]) | ||
41 | +]]), | ||
42 | + [libpcap_ver8=yes], | ||
43 | + [libpcap_ver8=no], | ||
44 | + [libpcap_ver8=yes] | ||
45 | +) | ||
46 | |||
47 | -libpcap_ver7=no | ||
48 | AC_RUN_IFELSE(AC_LANG_PROGRAM([[ | ||
49 | #include <string.h> | ||
50 | #include <stdlib.h> | ||
51 | @@ -469,11 +468,11 @@ | ||
52 | exit(0); | ||
53 | |||
54 | exit(1); | ||
55 | -]]), [ | ||
56 | - libpcap_ver7=yes | ||
57 | -], [ | ||
58 | - libpcap_ver7=no | ||
59 | -]) | ||
60 | +]]), | ||
61 | + [libpcap_ver7=yes], | ||
62 | + [libpcap_ver7=no], | ||
63 | + [libpcap_ver7=yes] | ||
64 | +) | ||
65 | |||
66 | if test x$libpcap_ver8 = xyes ; then | ||
67 | AC_MSG_RESULT(>= 0.8.0) | ||
68 | @@ -761,8 +760,8 @@ | ||
69 | |||
70 | have_bpf=no | ||
71 | dnl Check for BSD's BPF | ||
72 | -AC_MSG_CHECKING(for BPF device sending support) | ||
73 | -AC_TRY_RUN([ | ||
74 | +AC_CACHE_CHECK([for BPF device sending support], ac_cv_have_bpf, | ||
75 | +[AC_TRY_RUN([ | ||
76 | #include <stdio.h> | ||
77 | #include <stdlib.h> | ||
78 | #include <sys/types.h> | ||
79 | @@ -796,8 +795,11 @@ | ||
80 | [Do we have BPF device support?]) | ||
81 | AC_MSG_RESULT(yes) | ||
82 | have_bpf=yes | ||
83 | -],[ | ||
84 | - AC_MSG_RESULT(no) | ||
85 | +], | ||
86 | +[AC_MSG_RESULT(no)], | ||
87 | +[AC_MSG_ERROR([cross-compiling, | ||
88 | + presetting ac_cv_have_bpf=(yes|no) will help])] | ||
89 | +) | ||
90 | ]) | ||
91 | |||
92 | |||
diff --git a/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-fix-unable-to-link-libpcap-issue.patch b/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-fix-unable-to-link-libpcap-issue.patch deleted file mode 100644 index 5f36c68c9..000000000 --- a/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-fix-unable-to-link-libpcap-issue.patch +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | Uptream-Status: Pending | ||
2 | |||
3 | Signed-off-by: Zongchun Yu <Zongchun.Yu@freescale.com> | ||
4 | |||
5 | Index: tcpreplay-3.4.4/configure.ac | ||
6 | =================================================================== | ||
7 | --- tcpreplay-3.4.4.orig/configure.ac | ||
8 | +++ tcpreplay-3.4.4/configure.ac | ||
9 | @@ -389,7 +389,7 @@ CFLAGS="$CFLAGS -I$LPCAPINCDIR" | ||
10 | AC_SEARCH_LIBS([pcap_close], [pcap], | ||
11 | LPCAPLIB="$LIBS", | ||
12 | AC_ERROR([Unable to link libpcap in ${foundpcap}]), | ||
13 | - -lnl) | ||
14 | + -lnl-3) | ||
15 | |||
16 | AC_SUBST(LPCAPINC) | ||
17 | AC_SUBST(LPCAPLIB) | ||
diff --git a/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-improve-search-for-libpcap.patch b/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-improve-search-for-libpcap.patch deleted file mode 100644 index 50f024c67..000000000 --- a/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-improve-search-for-libpcap.patch +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | tcpreplay: improve search for libpcap | ||
2 | |||
3 | Add a test which will find libpcap if $testdir/.. is a sysroot. | ||
4 | |||
5 | Upstream-Status: Pending | ||
6 | |||
7 | Signed-off-by: Joe Slater <joe.slater@windriver.com> | ||
8 | |||
9 | |||
10 | --- a/configure.ac | ||
11 | +++ b/configure.ac | ||
12 | @@ -350,14 +350,20 @@ for testdir in $trypcapdir /usr/local /o | ||
13 | if test -f "${testdir}/include/pcap.h" -a $foundpcap = no ; then | ||
14 | LPCAPINC="${testdir}/include/pcap.h" | ||
15 | LPCAPINCDIR="${testdir}/include" | ||
16 | + # If testdir/.. is a sysroot, then sDir should point to where the libraries are. | ||
17 | + sDir=$(readlink -m ${testdir}/../${libdir}) | ||
18 | if test $dynamic_link = yes; then | ||
19 | - if test -f "${testdir}/lib64/libpcap${shrext_cmds}" ; then | ||
20 | + if test -f "${sDir}/libpcap${shrext_cmds}" ; then | ||
21 | + LPCAPLIB="-L${sDir} -lpcap" | ||
22 | + elif test -f "${testdir}/lib64/libpcap${shrext_cmds}" ; then | ||
23 | LPCAPLIB="-L${testdir}/lib64 -lpcap" | ||
24 | elif test -f "${testdir}/lib/libpcap${shrext_cmds}" ; then | ||
25 | LPCAPLIB="-L${testdir}/lib -lpcap" | ||
26 | else | ||
27 | AC_ERROR([Unable to find libpcap in ${testdir}]) | ||
28 | fi | ||
29 | + elif test -f "${sDir}/libpcap.${libext}" ; then | ||
30 | + LPCAPLIB="${sDir}/libpcap.${libext}" | ||
31 | elif test -f "${testdir}/lib64/libpcap.${libext}" ; then | ||
32 | LPCAPLIB="${testdir}/lib64/libpcap.${libext}" | ||
33 | elif test -f "${testdir}/lib/libpcap.${libext}" ; then | ||
diff --git a/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-no-bfp-support.patch b/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-no-bfp-support.patch deleted file mode 100644 index 3c11c922b..000000000 --- a/meta-networking/recipes-support/tcpreplay/files/tcpreplay-3.4.4-no-bfp-support.patch +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | Uptream-Status: Pending | ||
2 | |||
3 | Signed-off-by: Zongchun Yu <Zongchun.Yu@freescale.com> | ||
4 | |||
5 | --- a/configure.ac | ||
6 | +++ b/configure.ac | ||
7 | @@ -758,6 +758,8 @@ | ||
8 | AC_MSG_RESULT(no) | ||
9 | ]) | ||
10 | |||
11 | +ac_cv_have_bpf=no | ||
12 | + | ||
13 | have_bpf=no | ||
14 | dnl Check for BSD's BPF | ||
15 | AC_CACHE_CHECK([for BPF device sending support], ac_cv_have_bpf, | ||
diff --git a/meta-networking/recipes-support/tcpreplay/tcpreplay_3.4.4.bb b/meta-networking/recipes-support/tcpreplay/tcpreplay_3.4.4.bb deleted file mode 100644 index ccbab9f08..000000000 --- a/meta-networking/recipes-support/tcpreplay/tcpreplay_3.4.4.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | SUMMARY = "Use previously captured traffic to test network devices" | ||
2 | |||
3 | HOMEPAGE = "http://tcpreplay.synfin.net/" | ||
4 | SECTION = "net" | ||
5 | |||
6 | LICENSE = "GPLv3" | ||
7 | LIC_FILES_CHKSUM = "file://docs/LICENSE;md5=c33cccf72cc1603e8a72a84811ae3ac8" | ||
8 | |||
9 | SRC_URI = "http://prdownloads.sourceforge.net/tcpreplay/${PV}/tcpreplay-${PV}.tar.gz \ | ||
10 | file://tcpreplay-3.4.4-cross-compile.patch \ | ||
11 | file://tcpreplay-3.4.4-no-bfp-support.patch \ | ||
12 | file://tcpreplay-3.4.4-fix-unable-to-link-libpcap-issue.patch \ | ||
13 | file://tcpreplay-3.4.4-improve-search-for-libpcap.patch \ | ||
14 | " | ||
15 | SRC_URI[md5sum] = "22725feb9b2590809f9350308ec65180" | ||
16 | SRC_URI[sha256sum] = "7a809c58ddec86407fd6e5597ac883d7874a19bea81d716bb2b1c6e3b0e7b58f" | ||
17 | |||
18 | DEPENDS = "libpcap" | ||
19 | |||
20 | EXTRA_OECONF += "--with-libpcap=${STAGING_DIR_HOST}/usr" | ||
21 | |||
22 | inherit siteinfo autotools-brokensep | ||
23 | |||
diff --git a/meta-networking/recipes-support/tcpreplay/tcpreplay_4.1.1.bb b/meta-networking/recipes-support/tcpreplay/tcpreplay_4.1.1.bb new file mode 100644 index 000000000..389d61b58 --- /dev/null +++ b/meta-networking/recipes-support/tcpreplay/tcpreplay_4.1.1.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | SUMMARY = "Use previously captured traffic to test network devices" | ||
2 | |||
3 | HOMEPAGE = "http://tcpreplay.synfin.net/" | ||
4 | SECTION = "net" | ||
5 | |||
6 | LICENSE = "GPLv3" | ||
7 | LIC_FILES_CHKSUM = "file://docs/LICENSE;md5=890b830b22fd632e9ffd996df20338f8" | ||
8 | |||
9 | SRC_URI = "http://prdownloads.sourceforge.net/tcpreplay/${PV}/tcpreplay-${PV}.tar.gz \ | ||
10 | " | ||
11 | SRC_URI[md5sum] = "80394c33fe697b53b69eac9bb0968ae9" | ||
12 | SRC_URI[sha256sum] = "61b916ef91049cad2a9ddc8de6f5e3e3cc5d9998dbb644dc91cf3a798497ffe4" | ||
13 | |||
14 | DEPENDS = "libpcap" | ||
15 | |||
16 | EXTRA_OECONF += "--with-libpcap=${STAGING_DIR_HOST}/usr" | ||
17 | |||
18 | inherit siteinfo autotools-brokensep | ||
19 | |||