summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/tcpdump/tcpdump_4.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/tcpdump/tcpdump_4.6.1.bb')
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpdump_4.6.1.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/tcpdump/tcpdump_4.6.1.bb b/meta-networking/recipes-support/tcpdump/tcpdump_4.6.1.bb
new file mode 100644
index 000000000..1fdaf308d
--- /dev/null
+++ b/meta-networking/recipes-support/tcpdump/tcpdump_4.6.1.bb
@@ -0,0 +1,51 @@
1SUMMARY = "A sophisticated network protocol analyzer"
2HOMEPAGE = "http://www.tcpdump.org/"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1d4b0366557951c84a94fabe3529f867"
5SECTION = "console/network"
6DEPENDS = "libpcap"
7
8SRC_URI = " \
9 http://www.tcpdump.org/release/${BP}.tar.gz \
10 file://configure.patch \
11 file://unnecessary-to-check-libpcap.patch \
12 file://tcpdump-configure-dlpi.patch \
13 file://tcpdump-cross-getaddrinfo.patch \
14 file://add-ptest.patch \
15 file://run-ptest \
16"
17SRC_URI[md5sum] = "dab267ec30216a069747d10314079ec7"
18SRC_URI[sha256sum] = "4c88c2a9aeb4047074f344fc9b2b6577b219972d359e192f6d12ccf983a13fd7"
19export LIBS=" -lpcap"
20
21inherit autotools-brokensep ptest
22CACHED_CONFIGUREVARS = "ac_cv_linux_vers=${ac_cv_linux_vers=2}"
23
24PACKAGECONFIG ??= "openssl ipv6"
25PACKAGECONFIG[openssl] = "--with-crypto=yes, --without-openssl --without-crypto, openssl"
26PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
27
28EXTRA_AUTORECONF += " -I m4"
29
30do_configure_prepend() {
31 mkdir -p ${S}/m4
32 if [ -f aclocal.m4 ]; then
33 mv aclocal.m4 ${S}/m4
34 fi
35 # AC_CHECK_LIB(dlpi.. was looking to host /lib
36 sed -i 's:-L/lib::g' ./configure.in
37}
38do_configure_append() {
39 sed -i 's:-L/usr/lib::' ./Makefile
40 sed -i 's:-Wl,-rpath,${STAGING_LIBDIR}::' ./Makefile
41 sed -i 's:-I/usr/include::' ./Makefile
42}
43
44do_install_append() {
45 # tcpdump 4.0.0 installs a copy to /usr/sbin/tcpdump.4.0.0
46 rm -f ${D}${sbindir}/tcpdump.${PV}
47}
48
49do_compile_ptest() {
50 oe_runmake buildtest-TESTS
51}