summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/nis/ypbind-mt_1.36.bb')
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt_1.36.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb b/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb
new file mode 100644
index 000000000..35ef16a89
--- /dev/null
+++ b/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb
@@ -0,0 +1,52 @@
1# This package builds the NIS ypbind daemon
2# The source package is utils/net/NIS/ypbind-mt
3#
4PR = "r3"
5DESCRIPTION="\
6Multithreaded NIS bind service (ypbind-mt). \
7ypbind-mt is a complete new implementation of a NIS \
8binding daemon for Linux. It has the following \
9features. Supports ypbind protocol V1 and V2. \
10Uses threads for better response. Supports multiple \
11domain bindings. Supports /var/yp/binding/* file \
12for Linux libc 4/5 and glibc 2.x. Supports a list \
13of known secure NIS server (/etc/yp.conf) Binds to \
14the server which answered as first."
15HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
16
17require nis.inc
18
19LIC_FILES_CHKSUM = "file://COPYING;md5=082c9a0886c7c3db1bc862b5b62ffe08"
20
21SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \
22 file://ypbind-yocto.init \
23 file://ypbind.service \
24"
25SRC_URI[md5sum] = "135834db97d78ff6d79fdee2810b4056"
26SRC_URI[sha256sum] = "0eff76c1849f4b38ea1a60280d8397c4240369c641fe5402ce57edf1a90958c7"
27
28# ypbind-mt now provides all the functionality of ypbind
29# and is used in place of it.
30PROVIDES += "ypbind"
31
32CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true"
33
34do_install_append () {
35 install -d ${D}${sysconfdir}/init.d
36 install -d ${D}${sysconfdir}/rcS.d
37
38 install -m 0755 ${WORKDIR}/ypbind-yocto.init ${D}${sysconfdir}/init.d/ypbind
39
40 # TODO, use update-rc.d
41 ln -s ../init.d/ypbind ${D}${sysconfdir}/rcS.d/S44ypbind
42
43 install -d ${D}${systemd_unitdir}/system
44 install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
45}
46
47inherit systemd
48
49RPROVIDES_${PN} += "${PN}-systemd"
50RREPLACES_${PN} += "${PN}-systemd"
51RCONFLICTS_${PN} += "${PN}-systemd"
52SYSTEMD_SERVICE_${PN} = "ypbind.service"