summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/nis/yp-tools_2.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/nis/yp-tools_2.12.bb')
-rw-r--r--meta-networking/recipes-support/nis/yp-tools_2.12.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/nis/yp-tools_2.12.bb b/meta-networking/recipes-support/nis/yp-tools_2.12.bb
new file mode 100644
index 000000000..001784550
--- /dev/null
+++ b/meta-networking/recipes-support/nis/yp-tools_2.12.bb
@@ -0,0 +1,31 @@
1# This package builds tools to manage NIS
2# The source package is utils/net/NIS/yp-tools
3#
4PR = "r3"
5DESCRIPTION="\
6Network Information Service tools. \
7This package contains ypcat, ypmatch, ypset, \
8ypwhich, yppasswd, domainname, nisdomainname \
9and ypdomainname."
10
11require nis.inc
12SRC_URI = "http://www.linux-nis.org/download/yp-tools/${BP}.tar.bz2 \
13 file://domainname.service \
14"
15
16SRC_URI[md5sum] = "ce1e06d86caa285fa8cd76fdf103f51e"
17SRC_URI[sha256sum] = "6ae8321666eea7837da343eea90ea30273fb74943ad111d5a4befd2afb252063"
18
19CACHED_CONFIGUREVARS += "ac_cv_prog_STRIP=/bin/true"
20
21inherit systemd
22
23RPROVIDES_${PN} += "${PN}-systemd"
24RREPLACES_${PN} += "${PN}-systemd"
25RCONFLICTS_${PN} += "${PN}-systemd"
26SYSTEMD_SERVICE_${PN} = "domainname.service"
27
28do_install_append() {
29 install -d ${D}${systemd_unitdir}/system
30 install -m 0644 ${WORKDIR}/domainname.service ${D}${systemd_unitdir}/system
31}