diff options
Diffstat (limited to 'meta-networking/recipes-support/ndisc6/ndisc6_1.0.6.bb')
-rw-r--r-- | meta-networking/recipes-support/ndisc6/ndisc6_1.0.6.bb | 72 |
1 files changed, 72 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ndisc6/ndisc6_1.0.6.bb b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.6.bb new file mode 100644 index 0000000000..6861314a0a --- /dev/null +++ b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.6.bb | |||
@@ -0,0 +1,72 @@ | |||
1 | DESCRIPTION = "This package includes some useful diagnostics tools for \ | ||
2 | IPv6 networks, including ndisc6, rdisc6, tcptraceroute6 and traceroute6." | ||
3 | SECTION = "net" | ||
4 | HOMEPAGE = "http://www.remlab.net/ndisc6/" | ||
5 | LICENSE = "GPL-2.0-only" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
7 | |||
8 | SRCREV = "7e314b23329f9c24c4c097b8513673fed7e7158a" | ||
9 | SRC_URI = "git://git.remlab.net/git/ndisc6.git;protocol=http;branch=master \ | ||
10 | file://0001-autogen-Do-not-symlink-gettext.h-from-build-host.patch \ | ||
11 | " | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | DEPENDS = "coreutils-native" | ||
16 | |||
17 | inherit autotools gettext | ||
18 | |||
19 | EXTRA_OECONF += "PERL=${USRBINPATH}/perl" | ||
20 | |||
21 | USE_NLS = "yes" | ||
22 | |||
23 | EXTRA_OECONF += "--disable-rpath" | ||
24 | |||
25 | do_configure:prepend() { | ||
26 | cp ${STAGING_DATADIR_NATIVE}/gettext/gettext.h ${S}/include | ||
27 | ${S}/autogen.sh | ||
28 | } | ||
29 | |||
30 | do_install:append () { | ||
31 | rm -rf ${D}${localstatedir} | ||
32 | # Enable SUID bit for applications that need it | ||
33 | chmod 4555 ${D}${bindir}/rltraceroute6 | ||
34 | chmod 4555 ${D}${bindir}/ndisc6 | ||
35 | chmod 4555 ${D}${bindir}/rdisc6 | ||
36 | } | ||
37 | ALLOW_EMPTY:${PN} = "1" | ||
38 | |||
39 | # Split into seperate packages since we normal don't want them all | ||
40 | # The main package is left empty and therefore not created. | ||
41 | PACKAGES += "${PN}-ndisc6 ${PN}-tcpspray6 ${PN}-rdisc6 \ | ||
42 | ${PN}-tcptraceroute6 ${PN}-rltraceroute6 \ | ||
43 | ${PN}-tracert6 ${PN}-rdnssd ${PN}-misc" | ||
44 | FILES:${PN} = "" | ||
45 | FILES:${PN}-ndisc6 = "${bindir}/ndisc6" | ||
46 | FILES:${PN}-tcpspray6 = "${bindir}/tcpspray6" | ||
47 | FILES:${PN}-rdisc6 = "${bindir}/rdisc6" | ||
48 | FILES:${PN}-tcptraceroute6 = "${bindir}/tcptraceroute6" | ||
49 | FILES:${PN}-rltraceroute6 = "${bindir}/rltraceroute6" | ||
50 | FILES:${PN}-tracert6 = "${bindir}/tracert6" | ||
51 | FILES:${PN}-rdnssd = "${sbindir}/rdnssd ${sysconfdir}/rdnssd" | ||
52 | FILES:${PN}-misc = "${bindir}/dnssort ${bindir}/name2addr ${bindir}/tcpspray ${bindir}/addr2name" | ||
53 | |||
54 | DESCRIPTION:${PN}-ndisc6 = "ICMPv6 Neighbor Discovery tool. \ | ||
55 | Performs IPv6 neighbor discovery in userland. Replaces arping from the \ | ||
56 | IPv4 world." | ||
57 | DESCRIPTION:${PN}-rdisc6 = "ICMPv6 Router Discovery tool. \ | ||
58 | Queries IPv6 routers on the network for advertised prefixes. Can be used \ | ||
59 | to detect rogue IPv6 routers, monitor legitimate IPv6 routers." | ||
60 | DESCRIPTION:${PN}-tcpspray6 = "Performs bandwidth measurements of TCP \ | ||
61 | sessions between the local system and a remote echo server in either IPv6 \ | ||
62 | or IPv4." | ||
63 | |||
64 | DESCRIPTION:${PN}-rdnssd = "Daemon to autoconfigure the list of DNS \ | ||
65 | servers through slateless IPv6 autoconfiguration." | ||
66 | |||
67 | # The tcptraceroute6 and tracert6 commands depend on rltraceroute6 to | ||
68 | # perform the actual trace operation. | ||
69 | RDEPENDS:${PN}-tcptraceroute6 = "${PN}-rltraceroute6" | ||
70 | RDEPENDS:${PN}-tracert6 = "${PN}-rltraceroute6" | ||
71 | RDEPENDS:${PN}-misc += "perl" | ||
72 | |||