summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb')
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
new file mode 100644
index 000000000..ca1026229
--- /dev/null
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Utilities for managing the Linux LoWPAN stack"
2DESCRIPTION = "This is a set of utils to manage the Linux LoWPAN stack. \
3The LoWPAN stack aims for IEEE 802.15.4-2003 (and for lesser extent IEEE 802.15.4-2006) compatibility."
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8DEPENDS = "libnl python"
9
10PV = "0.3.1+git${SRCPV}"
11SRC_URI = "git://git.code.sf.net/p/linux-zigbee/linux-zigbee \
12 file://no-help2man.patch"
13SRCREV = "38f42dbfce9e13629263db3bd3b81f14c69bb733"
14
15S = "${WORKDIR}/git"
16
17inherit autotools python-dir pkgconfig
18
19CACHED_CONFIGUREVARS += "am_cv_python_pythondir=${PYTHON_SITEPACKAGES_DIR}/lowpan-tools"
20
21do_install_append() {
22 rmdir ${D}${localstatedir}/run
23}
24
25FILES_${PN}-dbg += "${libexecdir}/lowpan-tools/.debug/"
26
27PACKAGES =+ "${PN}-python"
28FILES_${PN}-python = "${libdir}/python*"