summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libcpr/libcpr_1.10.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/libcpr/libcpr_1.10.5.bb')
-rw-r--r--meta-networking/recipes-support/libcpr/libcpr_1.10.5.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/libcpr/libcpr_1.10.5.bb b/meta-networking/recipes-support/libcpr/libcpr_1.10.5.bb
new file mode 100644
index 000000000..93fdb78eb
--- /dev/null
+++ b/meta-networking/recipes-support/libcpr/libcpr_1.10.5.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Curl for People - C++ Requests"
2DESCRIPTION = "Curl for People C++ Requests is a simple wrapper around \
3 libcurl inspired by the excellent Python Requests project."
4HOMEPAGE = "https://docs.libcpr.org/"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=08beaae5deae1c43c065592da8f38095"
8
9DEPENDS = "curl openssl"
10
11SRC_URI = "git://github.com/libcpr/cpr.git;protocol=https;branch=1.10.x"
12SRCREV = "3b15fa82ea74739b574d705fea44959b58142eb8"
13
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18# building tests is currently using FetchContent for mongoose
19EXTRA_OECMAKE += "\
20 -DCPR_USE_SYSTEM_CURL=ON \
21 -DCPR_BUILD_TESTS=OFF \
22"
23
24BBCLASSEXTEND = "native nativesdk"