summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb')
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb b/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb
new file mode 100644
index 000000000..f733a7832
--- /dev/null
+++ b/meta-networking/recipes-support/dovecot/dovecot_2.2.10.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Dovecot is an open source IMAP and POP3 email server"
2DESCRIPTION = "Dovecot is an open source IMAP and POP3 email server for Linux/UNIX-like systems, written with security primarily in mind. Dovecot is an excellent choice for both small and large installations. It's fast, simple to set up, requires no special administration and it uses very little memory."
3
4LICENSE = "LGPLv2.1 & MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a981379bd0f1c362f8d1d21515e5b30b"
6
7SRC_URI = "http://dovecot.org/releases/2.2/dovecot-${PV}.tar.gz \
8 file://0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch \
9 file://building-rquota_xdr.c-depend-on-rquota.h.patch \
10 "
11SRC_URI[md5sum] = "037e9c9e07d9dbff54dcff09f280fc8c"
12SRC_URI[sha256sum] = "75592483d40dc4f76cc3b41af40caa4be80478946a699d46846d5d03e4d2e09b"
13
14DEPENDS = "openssl xz zlib bzip2 libcap"
15
16inherit autotools pkgconfig
17
18PACKAGECONFIG ??= " \
19 ${@base_contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \
20 ${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
21 "
22
23PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
24PACKAGECONFIG[ldap] = "--with-ldap=plugin,--without-ldap,openldap,"
25
26# From native build in armv7a-hf/eglibc
27CACHED_CONFIGUREVARS += "i_cv_signed_size_t=no \
28 i_cv_gmtime_max_time_t=32 \
29 i_cv_signed_time_t=yes \
30 i_cv_mmap_plays_with_write=yes \
31 i_cv_fd_passing=yes \
32 i_cv_c99_vsnprintf=yes \
33 lib_cv___va_copy=yes \
34 lib_cv_va_copy=yes \
35 lib_cv_va_val_copy=yes \
36 "
37
38# hardcode epoll() to avoid running unsafe tests
39# BSD needs kqueue and uclibc poll()
40EXTRA_OECONF = " --with-ioloop=epoll"
41
42FILES_${PN}-staticdev += "${libdir}/dovecot/*/*.a"
43FILES_${PN}-dev += "${libdir}/dovecot/*.so"
44FILES_${PN}-dbg += "${libdir}/dovecot/*/.debug"
45