summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch')
-rw-r--r--meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch b/meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch
new file mode 100644
index 000000000..6d5b722ea
--- /dev/null
+++ b/meta-networking/recipes-support/dnsmasq/dnsmasq/parallel-make.patch
@@ -0,0 +1,19 @@
1The dnsmasq target depends on .configured and $(objs). .configured does an rm
2-f *.o. Yet the only thing telling make to build the .configured target before
3the $(objs) target was the order of the dependencies of the dnsmasq target. We
4can't rely on that order when doing a paralllel make build, so add an explicit
5rule to enforce that order.
6
7Signed-off-by: Christopher Larson <chris_larson@mentor.com>
8Upstream-status: Pending
9
10--- dnsmasq-2.68.orig/Makefile
11+++ dnsmasq-2.68/Makefile
12@@ -139,6 +139,8 @@ bloatcheck : $(BUILDDIR)/dnsmasq_baselin
13 @rm -f *.o
14 @touch $@
15
16+$(objs): .configured
17+
18 $(objs:.o=.c) $(hdrs):
19 ln -s $(top)/$(SRC)/$@ .