summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/cifs/cifs-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/cifs/cifs-utils_git.bb')
-rw-r--r--meta-networking/recipes-support/cifs/cifs-utils_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/cifs/cifs-utils_git.bb b/meta-networking/recipes-support/cifs/cifs-utils_git.bb
new file mode 100644
index 000000000..2b7a0dd66
--- /dev/null
+++ b/meta-networking/recipes-support/cifs/cifs-utils_git.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "A a package of utilities for doing and managing mounts of the Linux CIFS filesystem."
2HOMEPAGE = "http://wiki.samba.org/index.php/LinuxCIFS_utils"
3
4LICENSE = "GPLv3 & LGPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7PV = "5.9"
8PR = "r1"
9
10SRCREV = "353d491dcb5d69d31434abeb962c8e9a49c36867"
11SRC_URI = "git://git.samba.org/cifs-utils.git"
12
13S = "${WORKDIR}/git"
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap"
17# when enabled, it creates ${bindir}/cifscreds and --ignore-fail-on-non-empty in do_install_append is needed
18PACKAGECONFIG[cifscreds] = "--enable-cifscreds,--disable-cifscreds,keyutils"
19# when enabled, it creates ${sbindir}/cifs.upcall and --ignore-fail-on-non-empty in do_install_append is needed
20PACKAGECONFIG[cifsupcall] = "--enable-cifsupcall,--disable-cifsupcall,krb5 talloc keyutils"
21
22inherit autotools pkgconfig
23
24do_install_append() {
25 # Remove empty /usr/bin and /usr/sbin directories since the mount helper
26 # is installed to /sbin
27 rmdir --ignore-fail-on-non-empty ${D}${bindir} ${D}${sbindir}
28}
29
30RRECOMMENDS_${PN} = "kernel-module-cifs"