summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb')
-rw-r--r--meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
new file mode 100644
index 000000000..41a55c027
--- /dev/null
+++ b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Administration tool for arp packet filtering"
2PRIORITY = "optional"
3LICENSE = "GPL-2.0"
4SECTION = "console/network"
5
6PR = "r2"
7
8RDEPENDS_${PN} += "perl"
9
10LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
11SRC_URI = " \
12 ${SOURCEFORGE_MIRROR}/ebtables/arptables-v${PV}.tar.gz;name=arptables \
13 file://arptables-compile-install.patch \
14 file://arptables-init-busybox.patch \
15 file://arptables-arpt-get-target-fix.patch \
16 file://arptables-remove-bashism.patch \
17"
18SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5"
19SRC_URI[arptables.sha256sum] = "e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928"
20
21S = "${WORKDIR}/arptables-v${PV}"
22
23do_compile () {
24 oe_runmake
25}
26
27# the install target is not multi-job safe, but it doesn't do much
28# so we just install serially
29#
30PARALLEL_MAKEINST = "-j1"
31
32fakeroot do_install () {
33 oe_runmake 'BINDIR=${sbindir}' 'MANDIR=${mandir}/' 'DESTDIR=${D}' install
34}