summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/aoetools/aoetools/makefile-add-ldflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/aoetools/aoetools/makefile-add-ldflags.patch')
-rw-r--r--meta-networking/recipes-support/aoetools/aoetools/makefile-add-ldflags.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/aoetools/aoetools/makefile-add-ldflags.patch b/meta-networking/recipes-support/aoetools/aoetools/makefile-add-ldflags.patch
new file mode 100644
index 000000000..726d8c564
--- /dev/null
+++ b/meta-networking/recipes-support/aoetools/aoetools/makefile-add-ldflags.patch
@@ -0,0 +1,31 @@
1Add LDFLAGS variable to Makefile, make sure the extra linker flags can be passed.
2
3Upstream-Status: Pending
4
5Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
6
7diff --git a/Makefile b/Makefile
8index 0c56ade..79f2e2b 100644
9--- a/Makefile
10+++ b/Makefile
11@@ -68,17 +68,17 @@ clean :
12 rm -f ${CONF_SCRIPTS} ${AOE_PING_OBJ} ${AOE_CFG_OBJ} ${SANCHECK_OBJ} ${PROGS}
13
14 aoeping : ${AOE_PING_OBJ}
15- ${CC} ${CFLAGS} -o $@ ${AOE_PING_OBJ}
16+ ${CC} ${CFLAGS} ${LDFLAGS} -o $@ ${AOE_PING_OBJ}
17 aoeping.o : aoeping.c dat.h fns.h
18 ${CC} ${CFLAGS} -o $@ -c $<
19 linux.o : linux.c config.h
20 ${CC} ${CFLAGS} -o $@ -c $<
21 aoecfg: ${AOE_CFG_OBJ}
22- ${CC} ${CFLAGS} -o $@ ${AOE_CFG_OBJ}
23+ ${CC} ${CFLAGS} ${LDFLAGS} -o $@ ${AOE_CFG_OBJ}
24 aoecfg.o : aoecfg.c dat.h fns.h
25 ${CC} ${CFLAGS} -o $@ -c $<
26 aoe-sancheck : ${SANCHECK_OBJ}
27- -$(CC) $(CFLAGS) -o $@ ${SANCHECK_OBJ} $(SANCHECKLIBS)
28+ -$(CC) $(CFLAGS) ${LDFLAGS} -o $@ ${SANCHECK_OBJ} $(SANCHECKLIBS)
29 aoe-sancheck.o : aoe-sancheck.c
30 -$(CC) $(CFLAGS) -o $@ -c $<
31