summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch')
-rw-r--r--meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch
new file mode 100644
index 000000000..95f629298
--- /dev/null
+++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch
@@ -0,0 +1,27 @@
1Make the Makefile obey LDFLAGS.
2
3Upstream-Status: Pending
4
5--- a/src/Makefile.in 2006-04-02 18:29:42.000000000 +0400
6+++ b/src/Makefile.in 2010-04-16 17:51:31.000000000 +0400
7@@ -67,16 +67,16 @@ all: $(TARGETS)
8 @echo "Type 'make install' as root to install the software."
9
10 pppoe-sniff: pppoe-sniff.o if.o common.o debug.o
11- @CC@ -o pppoe-sniff pppoe-sniff.o if.o common.o debug.o
12+ @CC@ -o pppoe-sniff pppoe-sniff.o if.o common.o debug.o $(LDFLAGS)
13
14 pppoe-server: pppoe-server.o if.o debug.o common.o md5.o libevent/libevent.a @PPPOE_SERVER_DEPS@
15- @CC@ -o pppoe-server @RDYNAMIC@ pppoe-server.o if.o debug.o common.o md5.o $(PPPOE_SERVER_LIBS) -Llibevent -levent
16+ @CC@ -o pppoe-server @RDYNAMIC@ pppoe-server.o if.o debug.o common.o md5.o $(PPPOE_SERVER_LIBS) -Llibevent -levent $(LDFLAGS)
17
18 pppoe: pppoe.o if.o debug.o common.o ppp.o discovery.o
19- @CC@ -o pppoe pppoe.o if.o debug.o common.o ppp.o discovery.o
20+ @CC@ -o pppoe pppoe.o if.o debug.o common.o ppp.o discovery.o $(LDFLAGS)
21
22 pppoe-relay: relay.o if.o debug.o common.o
23- @CC@ -o pppoe-relay relay.o if.o debug.o common.o
24+ @CC@ -o pppoe-relay relay.o if.o debug.o common.o $(LDFLAGS)
25
26 pppoe.o: pppoe.c pppoe.h
27 @CC@ $(CFLAGS) '-DVERSION="$(VERSION)"' -c -o pppoe.o pppoe.c