summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch')
-rw-r--r--meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch142
1 files changed, 142 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch
new file mode 100644
index 000000000..189675942
--- /dev/null
+++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch
@@ -0,0 +1,142 @@
1Update the configure script to cross-compiling with OE. This hard-codes
2a few target paths, reworks a few tests to be more friendly for cross
3and drops other tests.
4
5Upstream-Status: Inappropriate [build system specific changes]
6
7Index: src/configure.in
8===================================================================
9--- rp-pppoe-3.8.orig/src/configure.in 2006-04-03 00:29:42.000000000 +1000
10+++ rp-pppoe-3.8/src/configure.in 2007-06-07 22:19:36.000000000 +1000
11@@ -5,6 +5,13 @@
12 dnl pppd directory for kernel-mode PPPoE
13 PPPD_DIR=ppp-2.4.1.pppoe2
14
15+dnl hard code some paths
16+PPPD=/usr/sbin/pppd
17+ID=/usr/bin/id
18+ECHO=/bin/echo
19+AC_ARG_VAR(PPPD)
20+AC_ARG_VAR(ID)
21+
22 AC_CONFIG_HEADER(config.h)
23
24 AC_PREFIX_DEFAULT(/usr)
25@@ -44,7 +51,7 @@
26 AC_MSG_RESULT($ac_cv_struct_sockaddr_ll)
27
28 if test "$ac_cv_struct_sockaddr_ll" = yes ; then
29-AC_DEFINE(HAVE_STRUCT_SOCKADDR_LL)
30+AC_DEFINE([HAVE_STRUCT_SOCKADDR_LL], [], [Have struct SOCKADDR_LL])
31 fi
32
33 dnl Check for N_HDLC line discipline
34@@ -55,7 +62,7 @@
35 ac_cv_n_hdlc=no)
36 AC_MSG_RESULT($ac_cv_n_hdlc)
37 if test "$ac_cv_n_hdlc" = yes ; then
38-AC_DEFINE(HAVE_N_HDLC)
39+AC_DEFINE([HAVE_N_HDLC], [], [Have N_HDLC])
40 fi
41
42 AC_ARG_ENABLE(plugin, [ --enable-plugin=pppd_src_path build pppd plugin], ac_cv_pluginpath=$enableval, ac_cv_pluginpath=no)
43@@ -100,13 +107,13 @@
44 if test "$ac_cv_header_linux_if_pppox_h" = yes ; then
45 if test "$ac_cv_pluginpath" != no ; then
46 LINUX_KERNELMODE_PLUGIN=rp-pppoe.so
47- AC_DEFINE(HAVE_LINUX_KERNEL_PPPOE)
48+ AC_DEFINE([HAVE_LINUX_KERNEL_PPPOE], [], [Have kernel PPPoE])
49 PPPD_INCDIR=$ac_cv_pluginpath
50 fi
51 fi
52
53 if test "$ac_cv_debugging" = "yes" ; then
54- AC_DEFINE(DEBUGGING_ENABLED)
55+ AC_DEFINE([DEBUGGING_ENABLED], [], [Debugging enabled])
56 fi
57
58 AC_SUBST(LINUX_KERNELMODE_PLUGIN)
59@@ -131,15 +138,8 @@
60 AC_CHECK_SIZEOF(unsigned int)
61 AC_CHECK_SIZEOF(unsigned long)
62
63-dnl Check for location of pppd
64-AC_PATH_PROG(PPPD, pppd, NOTFOUND, $PATH:/sbin:/usr/sbin:/usr/local/sbin)
65-AC_PATH_PROG(ECHO, echo, echo)
66-
67-dnl Check for setsid (probably Linux-specific)
68-AC_PATH_PROG(SETSID, setsid, "", $PATH:/sbin:/usr/sbin:/usr/local/sbin)
69-
70 dnl Check for an "id" which accepts "-u" option -- hack for Solaris.
71-AC_PATH_PROG(ID, id, "", /usr/xpg4/bin:$PATH)
72+dnl AC_PATH_PROG(ID, id, "", /usr/xpg4/bin:$PATH)
73
74 dnl Check for Linux-specific kernel support for PPPoE
75 AC_MSG_CHECKING(for Linux 2.4.X kernel-mode PPPoE support)
76@@ -183,44 +183,8 @@
77 CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -ansi"
78 fi
79
80-dnl If we couldn't find pppd, die
81-if test "$PPPD" = "NOTFOUND"; then
82- AC_MSG_WARN([*** Oops! I couldn't find pppd, the PPP daemon anywhere.])
83- AC_MSG_WARN([*** You must install pppd, version 2.3.10 or later.])
84- AC_MSG_WARN([*** I will keep going, but it may not work.])
85- PPPD=pppd
86-fi
87-
88-dnl Figure out pppd version. 2.3.7 to 2.3.9 -- issue warning. Less than
89-dnl 2.3.7 -- stop
90-
91-PPPD_VERSION=`$PPPD --version 2>&1 | awk ' /version/ {print $NF}'`
92-
93-case "$PPPD_VERSION" in
94-1.*|2.0.*|2.1.*|2.2.*|2.3.0|2.3.1|2.3.2|2.3.3|2.3.4|2.3.5|2.3.6)
95- AC_MSG_WARN([*** Oops! Your version of pppd is $PPPD_VERSION, which is too old.])
96- AC_MSG_WARN([*** You need at least 2.3.7 (2.3.10 or newer recommended.])
97- AC_MSG_WARN([*** I will keep going, but it may not work.])
98- ;;
99-
100-2.3.7|2.3.8|2.3.9)
101- AC_MSG_WARN([*** Warning. Your version of pppd is $PPPD_VERSION. You will])
102- AC_MSG_WARN([*** not be able to use connect-on-demand. Upgrade to pppd])
103- AC_MSG_WARN([*** 2.3.10 or newer if you need connect-on-demand.])
104- ;;
105-
106-2*|3*|4*|5*|6*|7*|8*|9*)
107- ;;
108-
109-*)
110- AC_MSG_WARN([*** Oops. I cannot figure out what version of pppd you have.])
111- AC_MSG_WARN([*** All I got back was '$PPPD_VERSION'])
112- AC_MSG_WARN([*** I will keep going, but it may not work.])
113- ;;
114-esac
115-
116 dnl Figure out packing order of structures
117-AC_MSG_CHECKING([packing order of bit fields])
118+AC_CACHE_CHECK([packing order of bit fields],rpppoe_cv_pack_bitfields,[
119 AC_TRY_RUN([
120 union foo {
121 struct bar {
122@@ -245,10 +209,11 @@
123 }
124 }], rpppoe_cv_pack_bitfields=normal, rpppoe_cv_pack_bitfields=rev,
125 $ECHO "no defaults for cross-compiling"; exit 0)
126+])
127
128 if test "$rpppoe_cv_pack_bitfields" = "rev" ; then
129 AC_MSG_RESULT(reversed)
130- AC_DEFINE(PACK_BITFIELDS_REVERSED)
131+ AC_DEFINE([PACK_BITFIELDS_REVERSED], [], [Reversed bitfields])
132 else
133 AC_MSG_RESULT(normal)
134 fi
135@@ -312,6 +277,7 @@
136 AC_SUBST(RDYNAMIC)
137 AC_SUBST(LIBEVENT)
138 AC_SUBST(ECHO)
139+AC_SUBST(HAVE_STRUCT_SOCKADDR_LL)
140
141 datadir_evaluated=`eval echo $datadir`
142 AC_SUBST(datadir_evaluated)