summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-netkit/netkit-rwho/netkit-rwho/0001-Add-missing-include-path-to-I-options.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-netkit/netkit-rwho/netkit-rwho/0001-Add-missing-include-path-to-I-options.patch')
-rw-r--r--meta-networking/recipes-netkit/netkit-rwho/netkit-rwho/0001-Add-missing-include-path-to-I-options.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-networking/recipes-netkit/netkit-rwho/netkit-rwho/0001-Add-missing-include-path-to-I-options.patch b/meta-networking/recipes-netkit/netkit-rwho/netkit-rwho/0001-Add-missing-include-path-to-I-options.patch
new file mode 100644
index 000000000..b1325b317
--- /dev/null
+++ b/meta-networking/recipes-netkit/netkit-rwho/netkit-rwho/0001-Add-missing-include-path-to-I-options.patch
@@ -0,0 +1,46 @@
1From 55ab6f1389261edff5f4c942bc3b0d8e695856d7 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 30 Aug 2017 18:11:33 -0700
4Subject: [PATCH 1/2] Add missing include path to -I options
5
6Fixes errors like
7| rwho.c:52:10: fatal error: 'protocols/rwhod.h' file not found
8| #include <protocols/rwhod.h>
9| ^~~~~~~~~~~~~~~~~~~
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13Upstream-Status: Pending
14
15 rwho/Makefile | 1 +
16 rwhod/Makefile | 2 ++
17 2 files changed, 3 insertions(+)
18
19diff --git a/rwho/Makefile b/rwho/Makefile
20index 6f86388..67b28d4 100644
21--- a/rwho/Makefile
22+++ b/rwho/Makefile
23@@ -6,6 +6,7 @@ include ../MRULES
24 rwho: rwho.o
25 $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
26
27+CFLAGS += -I../include
28 rwho.o: ../version.h
29
30 install: rwho
31diff --git a/rwhod/Makefile b/rwhod/Makefile
32index 772b641..9034218 100644
33--- a/rwhod/Makefile
34+++ b/rwhod/Makefile
35@@ -7,6 +7,8 @@ ifneq ($(USE_GLIBC),1)
36 CFLAGS += -D_GNU_SOURCE
37 endif
38
39+CFLAGS += -I../include
40+
41 OBJS = rwhod.o
42
43 rwhod: $(OBJS)
44--
452.14.1
46