summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter/ipset/ipset_7.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-filter/ipset/ipset_7.21.bb')
-rw-r--r--meta-networking/recipes-filter/ipset/ipset_7.21.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-networking/recipes-filter/ipset/ipset_7.21.bb b/meta-networking/recipes-filter/ipset/ipset_7.21.bb
new file mode 100644
index 000000000..c7ebdc1c6
--- /dev/null
+++ b/meta-networking/recipes-filter/ipset/ipset_7.21.bb
@@ -0,0 +1,22 @@
1# Copyright (C) 2017 Aaron Brice <aaron.brice@datasoft.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Administration tool for IP sets"
5HOMEPAGE = "http://ipset.netfilter.org"
6LICENSE = "GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
8SECTION = "base"
9
10DEPENDS = "libtool libmnl"
11
12SRC_URI = "http://ftp.netfilter.org/pub/ipset/${BP}.tar.bz2 \
13 file://0001-ipset-Define-portable-basename-function.patch"
14SRC_URI[sha256sum] = "e2c6ce4fcf3acb3893ca5d35c86935f80ad76fc5ccae601185842df760e0bc69"
15
16inherit autotools pkgconfig module-base
17
18EXTRA_OECONF += "-with-kbuild=${KBUILD_OUTPUT} --with-ksource=${STAGING_KERNEL_DIR}"
19
20RRECOMMENDS:${PN} = "\
21 kernel-module-ip-set \
22"