summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb')
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
new file mode 100644
index 000000000..32cfc752b
--- /dev/null
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
@@ -0,0 +1,77 @@
1SUMMARY = "Filtering tool for a Linux-based bridging firewall"
2DESCRIPTION = "Utility for basic Ethernet frame filtering on a Linux bridge, \
3 advanced logging, MAC DNAT/SNAT and brouting."
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=53b4a999993871a28ab1488fdbd2e73e"
6SECTION = "console/network"
7PR = "r3"
8
9RDEPENDS_${PN} += "perl"
10
11RRECOMMENDS_${PN} += "kernel-module-ebtables \
12 "
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/ebtables/ebtables-v${PV}.tar.gz \
15 file://installnonroot.patch \
16 file://01debian_defaultconfig.patch \
17 file://ebtables.init \
18 file://ebtables.common \
19 file://ebtables.service \
20 file://no-as-needed.patch \
21"
22
23SRC_URI[md5sum] = "506742a3d44b9925955425a659c1a8d0"
24SRC_URI[sha256sum] = "dc6f7b484f207dc712bfca81645f45120cb6aee3380e77a1771e9c34a9a4455d"
25
26S = "${WORKDIR}/ebtables-v${PV}"
27
28inherit update-rc.d systemd
29
30EXTRA_OEMAKE = " \
31 BINDIR=${base_sbindir} \
32 MANDIR=${mandir} \
33 ETHERTYPESPATH=${sysconfdir} \
34 INITDIR=${sysconfdir}/init.d \
35 SYSCONFIGDIR=${sysconfdir}/default \
36 LIBDIR=${base_libdir}/ebtables \
37 'CC=${CC}' \
38 'CFLAGS=${CFLAGS}' \
39 'LDFLAGS=${LDFLAGS} -Wl,--no-as-needed' \
40 'LD=${LD}' \
41"
42
43do_install () {
44 install -d ${D}${sbindir}
45 install -m 0755 ${WORKDIR}/ebtables.common ${D}${sbindir}/ebtables.common
46 # Fix hardcoded paths in scripts
47 sed -i 's!/sbin/!${base_sbindir}/!g' ${D}${sbindir}/ebtables.common
48 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sbindir}/ebtables.common
49
50 install -d ${D}${sysconfdir}/init.d
51 install -d ${D}${sysconfdir}/default
52 install -d ${D}${sysconfdir}/ebtables
53 oe_runmake DESTDIR='${D}' install
54 install -m 0755 ${WORKDIR}/ebtables.init ${D}/${sysconfdir}/init.d/ebtables
55 mv ${D}${sysconfdir}/default/ebtables-config ${D}${sysconfdir}/default/ebtables
56 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/ebtables
57
58 # The script ebtables-save refernces perl in exec_prefix, so
59 # move it to sbindir to avoid QA issue
60 install -d ${D}/${sbindir}
61 mv ${D}/${base_sbindir}/ebtables-save ${D}/${sbindir}
62
63 # Install systemd service files
64 install -d ${D}${systemd_unitdir}/system
65 install -m 0644 ${WORKDIR}/ebtables.service ${D}${systemd_unitdir}/system
66 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/ebtables.service
67}
68
69CONFFILES_${PN} += "${sysconfdir}/default/ebtables"
70
71INITSCRIPT_NAME = "ebtables"
72INITSCRIPT_PARAMS = "start 41 S . stop 41 6 ."
73
74SYSTEMD_SERVICE_${PN} = "ebtables.service"
75
76FILES_${PN}-dbg += "${base_libdir}/ebtables/.debug"
77FILES_${PN} += "${base_libdir}/ebtables/*.so"