summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter/arno-iptables-firewall/arno-iptables-firewall_2.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-filter/arno-iptables-firewall/arno-iptables-firewall_2.1.2.bb')
-rw-r--r--meta-networking/recipes-filter/arno-iptables-firewall/arno-iptables-firewall_2.1.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-networking/recipes-filter/arno-iptables-firewall/arno-iptables-firewall_2.1.2.bb b/meta-networking/recipes-filter/arno-iptables-firewall/arno-iptables-firewall_2.1.2.bb
new file mode 100644
index 000000000..940454c3a
--- /dev/null
+++ b/meta-networking/recipes-filter/arno-iptables-firewall/arno-iptables-firewall_2.1.2.bb
@@ -0,0 +1,33 @@
1SUMMARY = "IPTables based firewall scripts"
2HOMEPAGE = "http://rocky.eld.leidenuniv.nl/joomla/index.php?option=com_content&view=article&id=45&Itemid=63"
3
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://gpl_license.txt;md5=11c7b65c4a4acb9d5175f7e9bf99c403"
6
7SRCREV = "c8dfd85b9e8e453e279525f30c1e3184c092f036"
8SRC_URI = "git://github.com/arno-iptables-firewall/aif;branch=master;protocol=https"
9
10S = "${WORKDIR}/git"
11
12inherit systemd
13
14do_install() {
15 install -d ${D}${sysconfdir} ${D}${sbindir} ${D}${bindir} ${D}${systemd_unitdir}/system ${D}${sysconfdir}/init.d
16 install -d ${D}${datadir}/arno-iptables-firewall ${D}${sysconfdir}/arno-iptables-firewall
17 cp -r ${S}${sysconfdir}/arno-iptables-firewall ${D}${sysconfdir}/
18 install -m 0755 ${S}${sysconfdir}/init.d/arno-iptables-firewall ${D}${bindir}
19 install -m 0755 ${S}/bin/arno-iptables-firewall ${D}${sbindir}
20 install -m 0755 ${S}/bin/arno-fwfilter ${D}${bindir}
21 cp -r ${S}/share/arno-iptables-firewall/* ${D}${datadir}/arno-iptables-firewall
22 cp -r ${S}/etc/arno-iptables-firewall/* ${D}${sysconfdir}/arno-iptables-firewall
23 install -m 0644 ${S}/lib/systemd/system/arno-iptables-firewall.service ${D}${systemd_unitdir}/system
24 sed -i -e 's%/usr/local/sbin%${bindir}%g' ${D}${systemd_unitdir}/system/arno-iptables-firewall.service
25 sed -i -e 's%/usr/local/sbin%${sbindir}%g' ${D}${bindir}/arno-iptables-firewall
26 sed -i -e 's%/usr/local%${exec_prefix}%g' ${D}${sysconfdir}/arno-iptables-firewall/firewall.conf
27 sed -i -e 's%#!/bin/bash%#!/bin/sh%g' ${D}${bindir}/arno-fwfilter
28 sed -i -e 's%#!/bin/bash%#!/bin/sh%g' ${D}${datadir}/arno-iptables-firewall/plugins/traffic-accounting-helper
29 sed -i -e 's%#!/bin/bash%#!/bin/sh%g' ${D}${datadir}/arno-iptables-firewall/plugins/dyndns-host-open-helper
30}
31
32SYSTEMD_SERVICE:${PN} = "arno-iptables-firewall.service"
33FILES:${PN} += "${systemd_unitdir}/system/arno-iptables-firewall.service"