diff options
Diffstat (limited to 'meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-libs.patch')
-rw-r--r-- | meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-libs.patch | 19 |
1 files changed, 14 insertions, 5 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-libs.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-libs.patch index 9a10f722f4..d2e58a3254 100644 --- a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-libs.patch +++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-libs.patch | |||
@@ -1,4 +1,8 @@ | |||
1 | Hardcode LIBS instead of using a script to determine available libs | 1 | From 328799d0cd5c523ad7a814fefec16d8a84aa8010 Mon Sep 17 00:00:00 2001 |
2 | From: Paul Eggleton <paul.eggleton@linux.intel.com> | ||
3 | Date: Tue, 16 Apr 2013 10:53:55 +0000 | ||
4 | Subject: [PATCH] Hardcode LIBS instead of using a script to determine | ||
5 | available libs | ||
2 | 6 | ||
3 | We want to avoid this dynamic detection so we have a deterministic | 7 | We want to avoid this dynamic detection so we have a deterministic |
4 | build. | 8 | build. |
@@ -7,15 +11,20 @@ Upstream-Status: Inappropriate [config] | |||
7 | 11 | ||
8 | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> | 12 | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> |
9 | 13 | ||
14 | --- | ||
15 | Makefile | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
10 | diff --git a/Makefile b/Makefile | 18 | diff --git a/Makefile b/Makefile |
19 | index 9e4f35f..3a5535d 100644 | ||
11 | --- a/Makefile | 20 | --- a/Makefile |
12 | +++ b/Makefile | 21 | +++ b/Makefile |
13 | @@ -5,7 +5,7 @@ | 22 | @@ -8,7 +8,7 @@ CFLAGS = -O2 -fPIE -fstack-protector --param=ssp-buffer-size=4 \ |
14 | #CFLAGS = -g | 23 | -D_FORTIFY_SOURCE=2 \ |
15 | CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion | 24 | #-pedantic -Wconversion |
16 | 25 | ||
17 | -LIBS = `./vsf_findlibs.sh` | 26 | -LIBS = `./vsf_findlibs.sh` |
18 | +LIBS = -lssl -lcrypto -lnsl -lresolv | 27 | +LIBS = -lssl -lcrypto -lnsl -lresolv |
19 | LINK = -Wl,-s | 28 | LINK = -Wl,-s |
29 | LDFLAGS = -fPIE -pie -Wl,-z,relro -Wl,-z,now | ||
20 | 30 | ||
21 | OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \ | ||