summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb')
-rw-r--r--meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
new file mode 100644
index 000000000..ea9cd1c24
--- /dev/null
+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
@@ -0,0 +1,69 @@
1SUMMARY = "Generic client/server library for SASL authentication"
2SECTION = "console/network"
3DEPENDS = "openssl virtual/db"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=3f55e0974e3d6db00ca6f57f2d206396"
6
7SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz \
8 file://avoid-to-call-AC_TRY_RUN.patch \
9 file://Fix-hardcoded-libdir.patch \
10 file://debian_patches_0009_sasldb_al.diff \
11 file://debian_patches_0014_avoid_pic_overwrite.diff \
12 file://sasl.h-include-stddef.h-for-size_t-on-NetBSD.patch \
13 "
14
15inherit autotools-brokensep pkgconfig useradd
16
17EXTRA_OECONF += "--with-dblib=berkeley \
18 --with-bdb-libdir=${STAGING_LIBDIR} \
19 --with-bdb-incdir=${STAGING_INCDIR} \
20 --with-bdb=db-5.3 \
21 --with-plugindir="${libdir}/sasl2/" \
22 andrew_cv_runpath_switch=none"
23
24PACKAGECONFIG ??= "ntlm \
25 ${@base_contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \
26 ${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
27 "
28PACKAGECONFIG[gssapi] = "--enable-gssapi=yes,--enable-gssapi=no,krb5,"
29PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
30PACKAGECONFIG[opie] = "--with-opie,--without-opie,opie,"
31PACKAGECONFIG[des] = "--with-des,--without-des,,"
32PACKAGECONFIG[ldap] = "--with-ldap=${STAGING_LIBDIR} --enable-ldapdb,--without-ldap --disable-ldapdb,openldap,"
33PACKAGECONFIG[ntlm] = "--with-ntlm,--without-ntlm,,"
34
35CFLAGS += "-fPIC"
36
37do_configure_prepend () {
38 rm -f acinclude.m4 config/libtool.m4
39
40 # make it be able to work with db 5.0 version
41 local sed_files="sasldb/db_berkeley.c utils/dbconverter-2.c"
42 for sed_file in $sed_files; do
43 sed -i 's#DB_VERSION_MAJOR == 4.*#(&) || DB_VERSION_MAJOR == 5#' $sed_file
44 done
45}
46
47do_compile_prepend () {
48 cd include
49 ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} makemd5.c -o makemd5
50 touch makemd5.o makemd5.lo makemd5
51 cd ..
52}
53
54USERADD_PACKAGES = "${PN}-bin"
55GROUPADD_PARAM_${PN}-bin = "--system mail"
56USERADD_PARAM_${PN}-bin = "--system --home=/var/spool/mail -g mail cyrus"
57
58SRC_URI[md5sum] = "a7f4e5e559a0e37b3ffc438c9456e425"
59SRC_URI[sha256sum] = "8fbc5136512b59bb793657f36fadda6359cae3b08f01fd16b3d406f1345b7bc3"
60
61PACKAGES =+ "${PN}-bin"
62
63FILES_${PN} += "${libdir}/sasl2/*.so*"
64FILES_${PN}-bin += "${bindir}"
65FILES_${PN}-dev += "${libdir}/sasl2/*.la"
66FILES_${PN}-dbg += "${libdir}/sasl2/.debug"
67FILES_${PN}-staticdev += "${libdir}/sasl2/*.a"
68
69INSANE_SKIP_${PN} += "dev-so"